• GoDaddy Community
  • VPS & Dedicated Servers
  • VPS & Dedicated Servers

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 

    InvisionPowerBoard 4.1 and PHP Version

    Right now GoDaddy offers php version 5.3, 5.4, 5.4 native and 5.5

    I'm running at 5.4 I want to go to 5.5 since Invision Power won't be supported on the next update so I want to make the switch to 5.5 to keep me up to date - ish.

    When i try to use 5.5 I get this message:

     

    PHP Requirements


    PHP version 5.5.33.
    cURL extension loaded
    You do not have the DOM PHP extension loaded which is required. You should contact your hosting provider or system administrator to ask for it to be enabled.
    You do not have the GD PHP extension loaded which is required. You should contact your hosting provider or system administrator to ask for it to be enabled.
    You do not have the Multibyte String PHP extension loaded which is required. You should contact your hosting provider or system administrator to ask for it to be installed.
    You do not have the MySQLi PHP extension loaded which is required. You should contact your hosting provider or system administrator to ask for it to be installed.
    OpenSSL extension loaded.
    Session extension loaded.
    SimpleXML extension loaded.
    XML Parser extension loaded.
    You do not have the XMLReader PHP extension loaded which is required. You should contact your hosting provider or system administrator to ask for it to be enabled.
    You do not have the XMLWriter PHP extension loaded which is required. You should contact your hosting provider or system administrator to ask for it to be enabled.
    You do not have the Zip PHP extension loaded. While this is not required, it is recommend. You may wish to contact your hosting provider or system administrator to ask for it to be installed.
    256M memory limit.
    No Suhosin restrictions.


    Additional Requirements
    ionCube Loader available.

     

    Thanks

    3 REPLIES 3
    Community Manager

    Hey @wolfe23

    Not sure this will help in your situation, but there are different PHP extensions you can manage when you update your PHP version in cPanel. You should see the option to enable or disable the extensions mentioned in your error message. It should look like this:

    phpmods.JPG

     

    You may want to check there to see if they are properly enabled. You can also check that using a PHP info script

     

    Anyone else in the community have thoughts on what could be wrong? Please let Wolfe know. 

     

    JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

    i'm using these settings: 

    and getting theses results... see files