• GoDaddy Community
  • VPS & Dedicated Servers
  • VPS & Dedicated Servers

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    New

    PHP 7.2 -- Update the severely outdated intl extension

    The only version of the Intl extension that Centos6/VHM/EasyApache4 will let you install for PHP7.2 is an old version (1.1.0) from 2009 with an ICU version of 4.2.1.... This is over 10 years old and causes compatibility issues with newer technologies, such as email communications in Magento 2.3.1.

     

    There is a constant that has been deprecated in PHP 7.2 called INTL_IDNA_VARIANT_2003; and programs that use it instead need to use the constant INTL_IDNA_VARIANT_UTS46. From my research, the ICU version needs to be at least 4.6 to support this constant.

     

    Is anyone familiar with updating the Intl extension from SSH? Is the Intl extension the only thing that needs updated or is there a separate ICU library on CentOS that would also need updated?

    3 REPLIES 3

    Re: PHP 7.2 -- Update the severely outdated intl extension

    Yeah, I am going totally nuts. Just need this one component & have to find a way to manually install ICU-4.6.1 by uninstalling PHP-INTL and reinstalling via PECL with the terminal and then reconfigure library default path but unable to get it to load. Must be already configured buried in a file. PECL doesn't work in the terminal and WHM module installers is unable to update INTL to 3.0.0 from current version. I wish it was available in the yum repos. There is a ICU-4.8 version as well.

     

    https://forum.oroinc.com/orocrm/orocrm-installationtechnical-issues-or-problems/topic/centos-6-4-icu... - This is a different server but the only one found.

     

    The only other option is to destroy CentOS 6.10 and rebuild new CentOS 7 as the next versions only work with the new configuration. I don't get it? Is there a doctor in the house...

    Highlighted
    Solution

    Re: PHP 7.2 -- Update the severely outdated intl extension

    I ended up just getting one of their Gen4 servers with preloaded CentOS 7. I was due for an upgrade anyways; Magento platform needs 8gb of RAM despite the advertised minimums to run well.

     

    I used the server migration tool which went a lot smoother than I had expected.

    Re: PHP 7.2 -- Update the severely outdated intl extension

    Yeah seemed to be the only recommendation on the table unfortunately my current self-managed VPS does not expire until April and needed an update now to get Magento working properly and after about two weeks of trying ended up outsourcing to someone with more experience that helped upgrade PHP version to work with intl extension and ICU components. Everything had to be done manually and well outside my range of skill set. It still doesn't make much sense to me that the yum repo didn't include other the versions ICU made for Centos 6 to solve situations with other newly released 3rd party apps. Just leaving people hanging out to dry. Hopefully no more surprises until then!