• GoDaddy Community
  • VPS & Dedicated Servers
  • VPS & Dedicated Servers

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    New

    Permission denied as root; needed setting for ElasticSearch

    I'm trying to run the following as root via SSH; but get permission denied. How can I set this?

     

    sysctl -w vm.max_map_count=262144

    I need this setting for ElasticSearch to run on my VPS

    12 REPLIES 12
    Highlighted
    Super User III
    Super User III

    Re: Permission denied as root; needed setting for ElasticSearch

    @aja206 

     

    I would update /etc/sysctl.conf as per https://www.elastic.co/guide/en/elasticsearch/reference/current/vm-max-map-count.html

     

    I also trying this on my VPS via the terminal in WHM and it worked fine



    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    New

    Re: Permission denied as root; needed setting for ElasticSearch

    Thanks for the response @PL281 ,

     

    I also came across that page and attempted this; however its not working on my CentOS6 VPS after setting that value in systl.conf and restarting the server. It will just keep displaying its original value. Maybe GoDaddy has a restriction for VPS users? I have the "Deluxe VPS Hosting" plan.

    Super User III
    Super User III

    Re: Permission denied as root; needed setting for ElasticSearch

    @aja206 

     

    I tested this on my Gen4 VPS (CentOS 7) and it worked - I can test it on my centOS 6 server later this evening and let you know - it should work unless it's a centOS 6 issue



    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    New

    Re: Permission denied as root; needed setting for ElasticSearch

    @PL281 Yes please let me know; I am curious if you would have trouble running that command on your CentOS 6 server.

     

    Is your hosting self-managed or managed?

    Super User III
    Super User III
    Solution

    Re: Permission denied as root; needed setting for ElasticSearch

    @aja206 

     

    This looks to be an issue with how the Virtualization on the VPS (Gen3) is implemented and that it won't let you adjust the VM memory settings - as I mentioned the new Gen4 VPS did allow me to run it - If you are based in the US you have to order it via uk.godaddy.com - they do have servers in the US Datacenter

     

    I event tried with running an update on /proc/sys/vm/max_map_count

     

     

    The issue is the /proc folder is not a "real" folder but rather virtualized folder of the operating system

     

    Sorry I couldn't be of more help 



    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    New

    Re: Permission denied as root; needed setting for ElasticSearch

    Thanks for the information @PL281 

     

    I want to start looking at getting a Gen4 VPS but I want to make sure it will be in the U.S.

     

    I spoke with a chat rep and he gave me the indication that I would have to wait until they release the product line on the U.S. website. As far as a timeline of when that would happen I was told "soon"

    Super User III
    Super User III

    Re: Permission denied as root; needed setting for ElasticSearch

    @aja206 

     

    Yes you can get it in the US datacenter - you just have to order it via uk.godaddy.com - I can tell you this as I've done this myself



    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    New

    Re: Permission denied as root; needed setting for ElasticSearch

    Hi @PL281 ,

     

    How do you get it to be in the US when you order it?

    Super User III
    Super User III

    Re: Permission denied as root; needed setting for ElasticSearch

    @aja206 

     

    After you order the server it will show up under your products in which you then have to "setup" the server - when you do this it will ask what region you want to set the server in

     



    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    New

    Re: Permission denied as root; needed setting for ElasticSearch

    Hi @PL281 

     

    I hope im not annoying you yet... I ended up getting a Gen4 server and im looking to use the Transfer Tool.... Did you have any issues of it giving you the message:

     

    "There is no SSH server listening on “xxxxx:22”: Unknown error; No error sent."

     

    I receive this despite entering correct credentials... The same information I use to connect using my SSH client....

    Super User III
    Super User III

    Re: Permission denied as root; needed setting for ElasticSearch

    @aja206 

     

    No I have not - the only thing I can think of is that I know I had a firewall plugin for WHM on my server and I had to add the IP address of the new server to the firewall



    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    New

    Re: Permission denied as root; needed setting for ElasticSearch

    @PL281 

     

    Thats exactly what it was....I had to whitelist the new IP for the sshd service on the old server....

     

    You sir need a tip jar on here. thx