• GoDaddy Community
  • VPS & Dedicated Servers
  • VPS & Dedicated Servers

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Helper V

    Where do I enable the 4 byte UTF-8 for mysql ?

    This might sound a tad bit ignorant to some of you out there, but for the life of me I can not find where I enable this...... I actually feel rather silly even asking, for it probably is some tiny button located in some spot I have checked out before... just over looking I hope??

    Anyhoo thank you!

    Coralie

     

    BTW I run drupal , I updated the core of drupal 7 and this feature has come up in my status report as disabled , thus want it enabled. I am not one to ask before looking myself, just can not find the information needed.

    Mrsroadrunner Photography
    6 REPLIES 6
    Community Manager

    Hi @mrsroadrunner

     

    I missed the opportunity on your first post, but welcome to GoDaddy Community!

     

    Per MySQL documentation, the utf8mb4 character set (4-Byte UTF-8 unicode encoding) is available on MySQL 5.5.3 or higher. You shouldn't need to turn it on if you're hosting has the right MySQL version. This would be available on our cPanel hosting accounts. If you have a Classic or Web Hosting account, the MySQL version wouldn't be high enough to support this. 

     

    I'm no database admin though, so perhaps I misunderstood your question. If anyone else in the community can speak to this, that would be awesome!

     

    JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

    @JesseW

    Thank you Jesse,

    The issue I had is where to turn this on at? I ran the drush commands, changed code per instructions, checked my database structure..... it just looks like to me I am going to have to change everything by hand......

    I think what I am going to do on this since it is not necessary but a option in drupal, is to hold off until or if this ever becomes necessary for my sites to function. 

    Since this is new, the drupal community which is a very active one, are talking. We will see what future posts over there come up with for this......

    I tend to make everything more complicated then it really is..... i just hope this is the case. Looks like what I really need is to spend time learning more about databases, not just how to make one and connect ......

    Thank you again for chiming in!

    Mrsroadrunner Photography

    @mrsroadrunner

     

    I'm not sure. I know that the character set is listed as part of the information_schema in databases on our cPanel hosting. If you have something other than that, can you share what it is? That might help us figure out if you're missing a step somewhere.

     

    JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

    @JesseW

     

    Hi there Jesse,

    I could not find it..... I just assumed this was my issue with the software I am running so I never even called into customer service about this... should I? I hate wasting peoples time with something that is my issue to figure out , you know?

    Mrsroadrunner Photography

    @mrsroadrunner I just noticed that you may be using SSH commands. If this is a dedicated hosting environment (VPS or Dedicated Server), the information I provided may not help. I found this article while researching your issue on line. Maybe it will be of help to:

    you. https://mathiasbynens.be/notes/mysql-utf8mb4

    I'm definitely not a server admin, so be careful with the information there. Since it wasn't written by us, I can't say for sure whether or not it will work or be 100% safe for you.

     

    JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

    @JesseW

     

    Thank you Jesse for your time and the information you placed here!

    I am running on a VPS. Regardless I will take the time to look over the link later on !

    Thank you again for your time on this!

    Coralie

    Mrsroadrunner Photography