• GoDaddy Community
  • Website Design & Development
  • Website Design & Development

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    New

    Fatal Error - Apache?

    Cannot serve directory /home/xxx/public_html/wp-content/themes/Extra/includes/builder/images/: No matching DirectoryIndex

     

    The above is an except from my errorlog
    GD say I need to discuss this with the Divi - Extra team. I agree but found this article which makes me want to check?

    Error except I used for a search. And found this?

    Cannot servedirectory /home/public_html/wp-content/themes/Extra/includes/builder/images/: No matching DirectoryIndex

     

    Reading Time: < 1 minute
    Pre-Flight Check
    • These instructions are intended specifically for solving the error: No matching DirectoryIndex (index.html) found.
    • I’ll be working from both Liquid Web Core Managed CentOS 6 and CentOS 7 servers, and I’ll be logged in as root.
    Apache Error for One General Reason
    This error may occur when attempting to access applications that have an index.php file (or other index file), but not an index.html or other specified ‘directory index’ file.
    For example, phpMyAdmin includes an index.php file upon installation, but not an index.html file.
    By default Apache is configured with the following:
    <IfModule dir_module>
DirectoryIndex index.html
</IfModule>
    …meaning that Apache will only look for directory index files that are named index.html.
    So, when attempting to access phpMyAdmin, Apache throws the following error:
    [autoindex:error] [pid 20115] [client 10.30.6.80:50800] AH01276: Cannot serve directory /usr/share/phpMyAdmin/: No matching DirectoryIndex (index.html) found, and server-generated directory index forbidden by Options directive

    In this case we want to add index.php to the DirectoryIndex directive.
    vim /etc/httpd/conf/httpd.conf
    Change:
    <IfModule dir_module>
DirectoryIndex index.html
</IfModule>
    to:
    <IfModule dir_module>
    DirectoryIndex index.html index.php
    </IfModule>
    Then exit and save the file with the command :wq .
    Be sure to restart Apache:
    systemctl restart httpd

     

    ? Best Nick









    1 ACCEPTED SOLUTION
    New

    Nopoe I was wrong, I increaded the meromory to 256mb in cpanel / Php version. Best

    View solution in original post

    1 REPLY 1
    New

    Nopoe I was wrong, I increaded the meromory to 256mb in cpanel / Php version. Best

    View solution in original post