• GoDaddy Community
  • Websites + Marketing | Website Builders
  • Websites + Marketing | Website Builders

    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 

    Blog post edits not saving to website

    I just started my blog and created 3 posts. I went in and made few edits and hit update. It gave me the message that my changes were updated to my website. When I view my website, the changes I made are not there. I even republished my blog again but that didn't work either. 

    2 REPLIES 2

    Hey @microBIOMETER,


    Have you tried clearing your local cache settings on your browser to be sure you're not viewing a cached version of your site page from before you published the updates? 


    Perhaps if you shared the name of the site you're trying to publish updates to, another member who's encountered a similar issue may be able to offer you some advice on how to resolve it. 


    CG - GoDaddy | Community Moderator
    24/7 support available at x.co/247support

    Hi there


    We are having same issue, the changes in post are not refreshed in the website. It's not browser cache, tried several different browsers and still seeing the Publish action successfully done but still no changes, thanks