• GoDaddy Community
  • Websites + Marketing | Website Builders
  • Websites + Marketing | Website Builders

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    Highlighted

    LimitRequestBody in .htaccess

    I am unable to post beyond a certain number of characters. I am hitting LimitRequestBody of apache server in my account.

    Getting error below.

    Request Entity Too Large
    The requested resource
    /vedic/wp-admin/post.php
    does not allow request data with GET requests, or the amount of data provided in the request exceeds the capacity limit.

    Additionally, a 413 Request Entity Too Large error was encountered while trying to use an ErrorDocument to handle the request.

    --------------------------

    I updated my .htaccess to the following:

    LimitRequestBody 2147483647

    --------------------------

    But still unable to post beyond a certain number.  I am unable to change LimitRequestBody  with my local .htaccess.

     

    Any ideas?

    1 REPLY 1
    Solution

    Re: LimitRequestBody in .htaccess

    Further details as per internet search. Please confirm. Thanks.

    Appears that the shared hosting Apache server has a 1 Meg LimitRequestBody setting.
    Since Apache is before PHP, Apache is the bottleneck, and in this case, PHP never gets my long posts.
    The shared hosting environment does not allow for form posts over 1 Meg, regardless of the downstream PHP settings. Ie: the PHP post_max_size and upload_max_filesize don't make a difference for form posts. When the form post is smaller, my PHP script DOES execute properly. Also, when I set LimitRequestBody to 3000 (3K), I can get my small form posts to fail with the same 413 error. So, I can make the limit smaller, but I cannot make the limit larger than 1 Meg.

     

    So you cannot do any form post more than 1Meg in godaddy shared hosting environment.