• GoDaddy Community
  • Websites + Marketing | Website Builders
  • Websites + Marketing | Website Builders

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution

    My web site says "not secure" at the top...

    Today I bought a domain name, email and hosting from godaddy.com.  I also was notified via email that I have a "free trial" for GoCentral. When I log into Godaddy, the cPanel admin lets me go to Wordpress.  So I built a web site, using Wordpress. That has its own issues, but I thought it was published.

     

    However, in the top bar it says "not secure" next to my web site address. Also, when my husband tested the contact page, the email sent through the web site didn't reach me.  When he used just my email address from his own email, it worked - just not through the site.

     

    I also clicked on "manage" for GoCentral, but its web site builder only lets me use a "godaddy" domain name and not the one I paid for. I am now stuck with a half-done website that apparently is not secure, or using GoCentral's web builder and ending up not using the domain name I paid for. (NHandPSolutions.com).

     

    I can't seem to find help in Wordpress about the "not secure" issue, or why the contact page isn't working. I also can't find help in GoDaddy for why, when I go to the web site builder (the free trial), it doesn't use the domain I bought.

     

    Help?

    4 REPLIES 4
    Super User II Super User II
    Super User II
    Solution

    Re: My web site says "not secure" at the top...

    @airheart41

     

    => For your WordPress site you have to purchase an SSL Certificate if you've not already done so.  Once GoDaddy installs that on your site those warnings should go away.   You just have to make sure WordPress is changed to https in the dashboard:  Settings > General: WordPress address and Site address fields.  You also need to make sure any http links within your content, widgets or sidebars are also https.

     

    => As far as email not working you can try a plugin called Easy SMTP which allows you to configure and send all outgoing emails via the SMTP server you use for your email in your email program.   You could also install Ninja Forms which keeps a copy of all form submissions on the site.  So if you don't get the email, you can just login to WordPress and view any submissions there.  Good idea even with Easy SMTP.

     

    => For GoCentral, you have to designate what domain you want to use.  When you login to GoCentral and preview your site at the top you'll see something like:

     

    https://nameofyoursite.godaddysites.com​  Use my domain

     

    "Use my domain" will click over to your domains for you to designate the domain you would like to use.

     

    If you only bought one domain and designated that for WordPress, it is not available for use on the GoCentral site.

     

    HTH! Smiley Wink

     

    Judith
    "Do one thing every day that scares you." ~ Eleanor Roosevelt

    Re: My web site says "not secure" at the top...

    Yikes, the SSL certificate is a little pricey. What is the "trusted site" thing that's offered for less than $5? What is that for? Not the same thing?

    Re: My web site says "not secure" at the top...

    One more question: I got 2 Go Central "free trials" listed on my products. Neither will let me cancel them. I want to be sure I am not charged for something I am not using. Do I need to contact customer service to make sure they're both canceled. I have no idea why there are two. 

    Super User II Super User II
    Super User II

    Re: My web site says "not secure" at the top...

    @airheart41

     

    I am basing my comments on what you describe, but do not have access to your account or service to know what is in place or not.

     

    Definitely contact GoDaddy to discuss both issues so you are clear what your options are, what needs to be done, and to ensure that what you do not want doesn't auto-renew. Smiley Wink

     

     

    Judith
    "Do one thing every day that scares you." ~ Eleanor Roosevelt