• GoDaddy Community
  • Websites + Marketing | Website Builders
  • Websites + Marketing | Website Builders

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    New

    Need to embed non-https audio player, GoCentral changes source to https

    I am trying to embed an audio player using HTML5 for our stations Icecast stream into the page using the GoCentral web designer. I embed the code, as follows, but when published, the GoCentral designer changes the source from http to http which breaks it. Is there some way to get the designer to not change the source of the stream to https?

     

    What I enter into the designer's field:
    <audio controls autoplay="autoplay"><source src="http://listen(redacted)" type="audio/mpeg">Your browser does not support the audio element.</audio>

    What it gets changed to:

    <audio controls autoplay="autoplay"><source src="https://listen(redacted)" type="audio/mpeg">Your browser does not support the audio element.</audio>

     

     

    5 REPLIES 5
    Super User II
    Super User II

    Re: Need to embed non-https audio player, GoCentral changes source to https

    Hello,

    Thank you for posting in Godaddy community.  You can try

    <audio controls autoplay="autoplay"><source src="//www.listen(redacted)" type="audio/mpeg">Your browser does not support the audio element.</audio>

     

    Also check it

     

    <figure>
    <figcaption>Listen to the T-Rex:</figcaption>
    <audio
    controls
    src="//examples.mp3">
    Your browser does not support the
    <code>audio</code> element.
    </audio>
    </figure>

    Zulfiqar Anees | GoDaddy Pro | Founder/CEO at FastTech Media, TechMag, and ZulWeb.
    New

    Re: Need to embed non-https audio player, GoCentral changes source to https

    No joy. Tried it with the port affixed too. This sort of audio stream expects an http header so the http:// part is required. Any other suggestions? I should note that setting up the music source for SSL will break it for the vast majority of users and players that access it.
    New

    Re: Need to embed non-https audio player, GoCentral changes source to https

    I realized after posting my reply that I would also note that I’ve configured the Icecast server so that any requests to port 80 forward to the Icecast server’s correct port (forwarding from 443 won’t work because there is no SSL cert or config for SSL on the server daemon), and any requests to the correct port of the Icecast server will assume to be client players unless the admin page is requested or source authentication is completed. This configuration has been tested and works fine when a player simply enters http://listen.myserver.net as the stream address. It eliminates the need to append :8001 and/or /stream to the URL, the making it much more user friendly. I just need to overcome the website builder’s changing that source URL from http to https when I don’t want it to. Maybe they need to add a “do you want to change this to https?” Option to the builder.
    New

    Re: Need to embed non-https audio player, GoCentral changes source to https

    Also, entering http://listen.myserver.net into a browser results in the player working okay in the browsers tab. As a workaround I’m setting up a link on on the page for http...
    New

    Re: Need to embed non-https audio player, GoCentral changes source to https

    Nobody has any ideas?