• GoDaddy Community
  • Websites + Marketing | Website Builders
  • Websites + Marketing | Website Builders

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 

    PHP Error Message: Fatal Error

    I am getting this crazy message intermittently when changing pages within the site. Does anyone know what it means or where I can go to get it resolved?

     

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 80 bytes) in/home/content/p3pnexwpnas10_data02/71/2742171/html/wp-includes/wp-db.php on line 1827

    3 REPLIES 3
    Super User II

    Hey, Scott:

     

    268M is on the high end of memory requirements! The error occurs when PHP is trying to process large database records or when importing or exporting.   Plugins are can be a big memory drain so you'll want to first try disabling all plugins then enabling one by one to see which triggers that error.

     

    Not knowing your site, you may want to try and clean things up to minimize the size of your database.  Removing any unused plugins, images, files can help.  Then use this WP-Optimize to clean things up:

     

    https://wordpress.org/plugins/wp-optimize/

     

    Also make sure all your plugins and themes are current.  If none of this solves the issue you'll want to get on the phone with GoDaddy to discuss options for more resources for your site. 

     

    HTH!  😉

    Judith
    "You have to be odd to be number one." Dr. Seuss

    Helper V

    @ScottFLL

     

    Hi there Scott,

    Try upping your memory limit in your php.ini folder......

    For instance, memory_limit = 60M , if that is not enough go up.....

    See if that works

    Wish you well on your project!

    Mrsroadrunner Photography

    In the cpanel find php version and you can change the php settings iry there including changing memore limits, and php version.