• GoDaddy Community
  • Websites + Marketing | Website Builders
  • Websites + Marketing | Website Builders

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    New

    Security Exception error in new website

    Hi, I just subscribe to GoDaddy yesterday. I uploaded my website, created with Visual Studio 2013.

    I am very new to VS 2013, and also Plesk. 

     

    When I open my domain, this error occurred; 

     

    ***QUOTE*****

    Security Exception

    Description: The application attempted to perform an operation not allowed by the security policy.  To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

    Exception Details: System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.ReflectionPermission, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

    *** END QUOTE***

    Please advice.

     

    Thank you in advance for advises and suggestions.

     

    7 REPLIES 7
    Super User II Super User II
    Super User II

    I don't use VS 2013 so... What does your web.config say under system.web? I have heard that <trust level="Full" /> will fix this?

     

    Try putting this in your web.config.

    <system.web>
     <securityPolicy>
       <trustLevel name="Full" policyFile="internal"/>
     </securityPolicy>
    </system.web>

    Not completely sure though. Anyone else?

    ...turns out that my two cents is worth less or more depending on the current exchange rate.

    roy darling *my posts seem a lot shorter in my head

    I have this exact same problem publishing an MVC site. It works beautifully locally and even connects to the SQL db that I have created in my Plesk account. I publish and get either the security exception or denied by profile if I put in the Full trust level. I will try the Policy File option to see if that helps.

     

    With over ten years with Godaddy, I have not had such a bad support experience. At least the first guy tried to find someone to help on a Saturday afternoon. The second support guy basically just said it is not their fault, get with MS for the correct settings.

     

    Is it time to ditch Godaddy when my sites are up?

    Nope ... still getting Security Exception: Request Failed. Help ... Godaddy phone support seems to have become useless.

    http://www.c-sharpcorner.com/article/how-to-host-your-Asp-Net-mvc-website-on-godaddy-server/

    Does this help anyone? I still get "program blocked by group policy" when trying to execute /bin/roslyn/csc.exe

    I am stucked on the same error you have mentioned. Can you please help me out ?

    Hello?  I have the same issue.. am I leaving godaddy if I want to continue using roslyn

    Nope. Not time to ditch Godaddy. This time on a call I still didn't get the solution, but I received a lengthy amount of help and direction to the solution. Roslyn CSC will not run on Godaddy shared hosting and there is no way to make it. I found https://social.msdn.microsoft.com/Forums/en-US/442b100a-2b88-4ac4-b655-0c1345791f15/roslyn-cscexe-we... and removed Roslyn from my project along with the precompile option listed. I haven't done any side-effect testing, but this looks extremely promising.