• GoDaddy Community
  • Websites + Marketing | Website Builders
  • Websites + Marketing | Website Builders

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 

    WebAPI Issue

    Hi
    
    Creating asp.net website using Web API is working on my localhost, after moved to godaddy server not working.
    Website not opening it says
    Forbidden - You do not have permission to access this document.
    Not Found - The requested document was not found on this server.(web api link)
    How to fix this issue? Please explain as soon as possible.
    test
    7 REPLIES 7
    Community Manager
    Community Manager

    Re: WebAPI Issue

    Hi @prabakaran8032

    I'm not a coding expert, but when I've seen that error before it usually means your code is looking for something that's not there. Since you coded the site on a local server, perhaps your code is referencing something still on your local system instead of a location on your server. 

    Does anyone else in the community with ASP.NET experience have more insight? 

     

     

    JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

    Re: WebAPI Issue

    I have encountered the same issue. Did you find the solution?

    Re: WebAPI Issue

    I had this issue when I placed my app in a folder, as opposed to the root of the website.  This is because a folder isn't an IIS application.

     

    Other caveats: if you want to use SSL, it won't work until you change the protocol for src="http://...jquery-2.0.3.min.js" to src="https://...jquery-2.0.3.min.js"  See the source code from this page to see this work (https://clickonmy.com/UTC.html)

    Re: WebAPI Issue

    I should also mention that, if you want your app in its own folder, you can do this by creating a Virtual Directory from (Plesk Hosting) Websites & Domains > your domain > Virtual Directories, then click Create Virtual Directory.  Just make sure the  'Create application' box is checked on the Create New Virtual Directory screen.

    Re: WebAPI Issue

    I have kind of similar issue. I can execute API methods where no "List" or "IEnumerable" instructions are used. If I have a line of code with any of those it immediately fails and shows:

    {
    "Message": "An error has occurred."
    }

     

    This does not seems to make any sense!, please help!

     

    Re: WebAPI Issue

    I have a similar issue, my ASP.Net Web API runs perfect locally, but deploying it gives me below error :

     

    Web Deployment task failed : The type initializer for 'Microsoft.Web.Deployment.DeploymentManager' threw an exception.) 

     

     

    Any help is appreciated.

    Re: WebAPI Issue

    I have php class which connects to mysqli though "mysql:// ……" and uses PDO. These API Services were working fine a week back but now its not working at all. This issue is happening for all of my clients who are using this source code from few. Godaddy says its script issue but I do not agree on it as there are no code changes made and it was working fine last week. Anybody facing same issue?? Please suggest a solution.