cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cakephp v 0.2.9 session expires after 24 minutesin go daddy

Cakephp v 0.2.9 session expires very quickly. It expire after every 24 minutes. I set i to 36 hours an cakephp config file and php.ini but both didn't work. Here is config file setting.

Configure::write('Session', 
  array( 'defaults' => 'php', 
         'timeout' => 1296000, 
         'cookieTimeout' => 1296000, 
         'ini' => array( 'session.gc_maxlifetime' => 1296000, 
                         'session.cookie_lifetime' => 1296000, 
                          'session.cache_expire' => 1296000 
                        ) 
          ))

and here is php.ini I amusing godaddy linux business hosting. Can you please help me out.
Here are php.ini file setting placed in root folder session.gc_maxlifetime = 12960000 session.cookie_lifetime = 12960000 session.cache_expire = 12960000

2 REPLIES 2
Community Manager

Hi @muhammad_mylo. Welcome to GoDaddy Community! 

 

I'm not sure why you're seeing this problem. If you haven't already done so, I'd suggest adding a PHP info script to your account so you can look at what the actual PHP settings are. Also, you may need to take action to get your php.ini file to take effect. Alternatively, if you use a .user.ini file instead, those changes should take effect immediately if they are supported. Hope that helps. If not, feel free to provide more information. Others in the community may be able to provide you with additional suggestions.

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

Hi there,

  I'm having issues with trying to get the session timer to increase beyond 24 mins as well.

 

  I have managed to setup the php.ini files and when I view the phpinfo.php page, it tells me that the local value has been changed.

  php-local-change.jpg

However, when I test it, it would still timeout after 24 minutes.

Any suggestions?

 

Thanks!