cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't access CPanel from Hosting Managment - Delegate access

So I've just discovered a big problem with GoDaddy and It's making me want to bang my head against the wall.

 

No matter what I do, I can't seem to access my CPanel. I have been given delegate access from my client. I log into my account, go to Delegate access and then access my client's account. Afterwards, when I click on the Manage button in the hosting tab, it just does nothing. It keeps on loading until I get this error.

Screenshot from 2020-04-20 06-23-30.png

I tried contacting GoDaddy Support but obviously to no avail. However, when I try accessing the CPanel through Mobile Hotspot from my phone, it loads up just fine. But that's no good as well as I keep getting an IP address changed error and keep getting logged out. I tried using a VPN, it didn't work. I tried using Tor, GoDaddy won't even let me log in there.

I can't do any work on the server, can't upload/update my site. Please help me with this or tat the very least, tell me what the problem is so that I can go find a fix myself.

1 REPLY 1

I am having the same issue with a delegate access account I should be able to manage. Can someone please look into this? Thank you!