Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Tuesday, August 3rd at 3pm PST / 6pm EST. Learn more
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Getting Started

Cannot receive emails in mailbox sent from WP form

I'm hosting a website in CPANEL with Wordpress and we are using Gravity Form so that people can send their resumes to us.


The problem is that we cannot receive an email with the form filled and attachements sent. (We just get the form filled out in WordPress and have to check there everytime.)


I've tried SMTP Mailer , Easy WP SMTP, WP-Mail-SMTP so that we can get it in our personnal email mailbox but nothing is going on. Apparently it's GoDaddy server who's blocking it or something.


How can I unable it so that we can get emails with attachements when people are filling out the form?



Getting Started

Funny, if I change the webmail address in the notifications settings to a gmail, hotmail or yahoo. I receive the email in their respective mailbox. But the corporate email that I have which is hosted on MS Exchange Online never gets it.

Getting Started

I've got my website hosted with GoDaddy under CPANEL and using WordPress as a CMS.


Our corporate email is hosted with Office 365 under Microsoft Exchange Online.

I've created an email in CPANEL called notifications@(our domain).com


In WP we created a form so that external users can send us their CV and resume to apply.

We use the to relay the emails received towards our corporate mailbox.


The problem is that we do not receive the emails in our mailbox when we put our corporate address to receive to and if I put a gmail or hotmail adress it works.


Is there something that GoDaddy is block through their servers? Because we tried everything on our part and we just can't get emails notifications in our mailbox.



You need to add your website IP address to your SPF record. This is found in your zone file as a TXT file. Simply add "ip4:youripaddress" to the text that is there.

Can you please elaborate in detail?


All you need to do is, go into the MX Records of the Email Preferences (within CPanel)

and change the Local Mail Exchange to Remote Mail Exchange. When the website tries sending emails to the email address with the website's domain name, the web server attempts to address it locally.

I'm experiencing the same issue across multiple sites running wordpress that are hosted with Godaddy. I've tried several times to get assistance from Godaddy tech support and they're giving me the run around. What's going on? It's killing my business.

Same here too. Any address but a godaddy one works.


Change your Wordpress Admin email to one that you want but bear in mind that if it is attached to the site ( that you will actually have to go into CPanel -> Default Address:  Send all unrouted email for the following domain: -> Forward to Email Address (any email here not related to your web)

It then forward all emails that your website sends including all form notifications.


I've found it a lot easier then messing with stuff that I could easily break 😉