cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
New

EasyApache upgrade

Hi,

I noticed that it’s advisable to upgrade to EasyApache 4 but when I tried I get the following message:

“EasyApache 4 is not available when EasyApache 3 is active.

If you would like to use EasyApache 4, the following url contains instructions on how to convert to EasyApache 4.”

 

I followed the instructions below ‘How to install EasyApache4.’

How to install EasyApache 4

To install EasyApache 4, perform the following steps on the command line as the root user:

  1. Run the following command:

 /scripts/migrate_ea3_to_ea4 –run

 

However, despite many attempts and changes of user and even different sites

I get the error message below.

 

commercialhotelp@commercialhotelpa.com.au [~]# /scripts/migrate_ea3_to_ea4 –run

Failed to mkdir(/usr/local/cpanel/logs/packman): Permission denied

 

 I would like to do the upgrade as it is recommended and EasyApache 3 will not be supported beyond early 2018, but at this stage I have run out of ideas. Any help would be appreciated.

Best regards

Melvyn Watson

 

 

1 REPLY 1

You must first become the root superuser.  Just use sudo:

 

sudo su

/scripts/migrate_ea3_to_ea4 –run