cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to make install on Magento 2.1.7 or latest on godaddy Cpanel Application Installer

Hi All,

 

How to make install on Magento 2.1.7 or latest on godaddy Cpanel Application Installer, I have tried it but I encountered this error below;

 

! The selected version 2.1.7 is not compatible with the selected install location.

Requirements:
php-version-maximum v7.0.99 (detected: v7.1.7)
php-zip-version-minimum v1 (detected: OFF)

 

Can you some give me a guide how to set-up with those error below?

 

Thanks

Jess

10 REPLIES 10
Helper VI
Helper VI

Re: How to make install on Magento 2.1.7 or latest on godaddy Cpanel Application Installer

Hi @jessp855, welcome to the community! 🙂

 

In order to make those changes, you need to login to your cpanel account and click in "Select PHP version", from there you can change to version 5.6, or any other version and click save.

After you clicked save, you will see a list of modules with a checkbox at the left. Look for the one that's named zip and enable it, then hit save again.

 

After that, try again the magento install.

 

Hope it helps!

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄

Re: How to make install on Magento 2.1.7 or latest on godaddy Cpanel Application Installer

Hi,

I got that when I reach at 8%

Installing: Error: An error occurred while executing the application API

How to debug this problem?

 

Thanks

Jess

Re: How to make install on Magento 2.1.7 or latest on godaddy Cpanel Application Installer

Hello @jessp855,

 

Your PHP configuration is missing these two PHP modules/extensions;

iconv
mbstring
 
 

Re: How to make install on Magento 2.1.7 or latest on godaddy Cpanel Application Installer

Hi RaaviRaghu

 

How to add this module/extension "iconv"?, "mbstring" already checkbox on PHP version, the way im using Cpanel version 11.62.0.20 on my godaddy hosting account.

 

Thanks

Jess

Re: How to make install on Magento 2.1.7 or latest on godaddy Cpanel Application Installer

[~/public_html]$ php -i | grep curl

Configure Command =>  './configure'  '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib64' '--libexecdir=/usr/libexec' '--sharedstatedir=/var/lib' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--target=x86_64-redhat-linux-gnu' '--program-prefix=' '--prefix=/opt/alt/php70' '--exec-prefix=/opt/alt/php70' '--bindir=/opt/alt/php70/usr/bin' '--sbindir=/opt/alt/php70/usr/sbin' '--sysconfdir=/opt/alt/php70/etc' '--datadir=/opt/alt/php70/usr/share' '--includedir=/opt/alt/php70/usr/include' '--libdir=/opt/alt/php70/usr/lib64' '--libexecdir=/opt/alt/php70/usr/libexec' '--localstatedir=/var' '--with-curl=/opt/alt/curlssl/usr' '--sharedstatedir=/usr/com' '--mandir=/opt/alt/php70/usr/share/man' '--infodir=/opt/alt/php70/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib64' '--with-config-file-path=/opt/alt/php70/etc' '--with-config-file-scan-dir=/opt/alt/php70/link/conf' '--disable-debug' '--with-pic' '--without-pear' '--with-bz2' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--with-webp-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl=/opt/alt/openssl' '--with-openssl-dir=/opt/alt/openssl' '--with-pcre-regex=/opt/alt/pcre/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-sockets=shared' '--enable-sysvsem=shared' '--enable-sysvshm=shared' '--enable-sysvmsg=shared' '--with-kerberos' '--enable-shmop' '--enable-calendar' '--with-libxml-dir=/opt/alt/libxml2/usr' '--enable-xml' '--with-mcrypt=shared,/usr' '--with-tidy=shared,/usr' '--with-readline' '--with-mhash' '--enable-dbx=shared' '--with-zlib-dir=/usr' '--enable-opcache' '--enable-opcache-file' '--enable-cgi' '--enable-pcntl' '--enable-fastcgi' '--with-imap=shared' '--with-imap-ssl=/opt/alt/openssl' '--enable-mbstring=shared' '--enable-mbregex' '--with-gd=shared' '--enable-bcmath=shared' '--enable-dba=shared' '--with-db4=/usr' '--with-xmlrpc=shared' '--with-ldap=shared' '--with-ldap-sasl' '--enable-dom=shared' '--with-pgsql=shared' '--enable-wddx=shared' '--with-snmp=shared,/opt/alt/net-snmp/usr' '--enable-soap=shared' '--with-xsl=shared,/usr' '--enable-xmlreader=shared' '--enable-xmlwriter=shared' '--with-icu-dir=/opt/alt/libicu/usr' '--enable-pdo=shared' '--with-pdo-pgsql=shared,/usr' '--with-pdo-sqlite=shared,/opt/alt/sqlite/usr' '--enable-json=shared' '--enable-zip=shared' '--with-pspell=shared' '--enable-phar=shared' '--enable-posix=shared' '--enable-fileinfo=shared' '--enable-intl=shared' '--with-enchant=shared,/usr' '--with-pdo-dblib=shared,/opt/alt/freetds/usr' '--with-interbase=shared,/usr' '--with-pdo-firebird=shared,/usr' '--with-unixODBC=shared,/usr' '--with-pdo-odbc=shared,unixODBC,/usr' 'build_alias=x86_64-redhat-linux-gnu' 'host_alias=x86_64-redhat-linux-gnu' 'target_alias=x86_64-redhat-linux-gnu'

curl

New

Re: How to make install on Magento 2.1.7 or latest on godaddy Cpanel Application Installer

The solution to the problem is to use PHP 7 (not 7.1)

Re: How to make install on Magento 2.1.7 or latest on godaddy Cpanel Application Installer

Still same nothing changes

Screen Shot 2018-09-13 at 12.49.24 AM.png

Re: How to make install on Magento 2.1.7 or latest on godaddy Cpanel Application Installer

Hi I installed Magento 2.1.8 in a public_html subfolder mydomain.com/store as i already have a live store and was planning to build a new site to test, but how do I access Magento Admin to do the setting. What URL would it have?Castor

Re: How to make install on Magento 2.1.7 or latest on godaddy Cpanel Application Installer

Hi I installed Magento 2.1.8 in a public_html subfolder mydomain.com/store as i already have a live store and was planning to build a new site to test, but how do I access Castor Magento Admin to do the setting. What URL would it have?

Re: How to make install on Magento 2.1.7 or latest on godaddy Cpanel Application Installer

Launch WHM,under softwares,click easyapache4,click php extensions,add mbstring,soap,zip etc. Installation will be smooth then.