cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution
GoDaddy Pro Artisan
GoDaddy Pro Artisan

How to set up custom php.ini files

Hi Friends,
I have created a video walk-through on " How to set up custom php.ini files."

Note: After modification, remove " phpinfo.php " file from public_html directory. It ensures, No one can able to view the information on PHP INI file.  

 

Update:  https://goo.gl/e81abo

 

A php.ini file contains directives for controlling many PHP settings. You can set up one or multiple custom php.ini files to define how your web site functions. For example, you might have a custom file in your /home/username/public_html directory for your web site's main pages, and a separate custom file in your /home/username/public_html/images directory for your web site's image files.

 

Connect to your shared hosting account with SSH
https://goo.gl/e81abo

How To Increase Memory Limit in Godaddy 2017
https://goo.gl/e81abo

 

If You find above video is helpful. Give me a kudos!.
Thank You.

Smiley Happy

8 REPLIES
GoDaddy Pro Trusted Advisor
GoDaddy Pro Trusted Advisor

Re: How to set up custom php.ini files

Hi @manojkumarcdo, it looks nice!

It probably would help new users to set it properly!

I'd recommend to remove the phpinfo from public_html/ for security reasons. Or at least rename it and put it in a password protected directory.

 

Cheers!

If you find my replies helpful, give me a like or kudo Smiley Happy
And if I solved your issue, mark it as solution Smiley Very Happy
mehernosh
Novice

Re: How to set up custom php.ini files

Hi, thanks for the video. However, these instructions seem to be for cpanel access, not for Managed Wordpress. I am unable to access the public_html folder with the FTP/SFTP access GoDaddy has provided. Nor does their Support Team indicate how I can access or setup php.ini files. Can you advise further? Your help is greatly appreciated.

GoDaddy Pro Artisan
GoDaddy Pro Artisan
Solution

Re: How to set up custom php.ini files

Lance
Apprentice

PHP INI not updating?

For whatever reason, changing my php.ini settings in /public_html isn't working. I've tried altering through shell (no permission to edit that file) and putting it in the root directory. I've killed php processes.  And I check it with phpinfo(). Nothing changes. It's been like this for days. And I can't launch my site because I utilize sessions and there's settings I want to alter to make them more secure.

I would ask godaddy what the deal is but their 24/7 support has been unavailable. The chat is always busy and I can't call the 24/7 support line because where I live there cell signal is bad and my calls drop. Any ideas? Did I forget a step? I looked all around the community, followed guides all around the site and community forums and nothing I've tried works.

flintwood
Novice

php.ini session.gc_maxlifetime

Hi all,

 

  I'm trying to change my website's session timer. I'm using CPanel and from the documentation I've read, I should just need to add a php.ini file to the public_html folder and in the php.ini file, have the line session.gc_maxlifetime = 3600, go into PHP process and kill all processes.

 

  But that didn't change the session timer. I was wondering if anyone can help please?

 

Thanks!

 

Ken

owensltd
Apprentice

Re: How to set up custom php.ini files

I followed the instructions and it will not work. I called godaddy and they told me i would have to pay for extra support to get it working.

Employee
Employee

Re: How to set up custom php.ini files

Good news!

 

There has been an issue preventing php.ini from loading in cPanel hosting. As of yesterday this has been corrected.

BTGsolutions
Apprentice

Re: How to set up custom php.ini files

I liked your video Incapio. https://www.youtube.com/watch?v=bnS3bwkrOkE 

Do you have a video that can help me setup the php.ini for a simple email form in a GoDaddy cpanel/Linux hosting environment?