cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Moodle installation issues

Hi all,

I need a bit of advice with installing moodle onto my VPS. First of all, I'm very new to this so still learning... please be gentle!

Currently using GoDaddy's 1GB offering, managed, with Linux cPanel. I've got most of the basics sorted.

 

I'm trying to install Moodle 3.2.2 (latest version) but getting the following errors:

Requirements:
php-version-minimum v5.6.5 (detected: v5.5.35)
php-memory-limit 40MB (detected: 32MB)

 

I have done a yum upgrade but it did not catch this one. Also, how do I increase the memory limit?

 

Any hints will be welcome, this is a good learning curve!

Michael

2 REPLIES 2
Solution

Re: Moodle installation issues

One problem solved - to change the memory limit, needed to use WHM --> Service Configuration --> PHP Configuration Editor, and the setting is in there

 

EDIT: Finished! After reading, I first migrated EasyApache to version 4 via command line

/scripts/migrate_ea3_to_ea4 --run

Then, just used that to install PHP version 5.6, 7.0 and 7.1

NB: Needed to use WHM -->Software-->MultiPHP INI Editor to change the memory allocation

mysql_full_unicode_support#File_format

Hello team,

 

I am facing that error on the subject when installing moodle 3.3+ any help please