cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
New

PHP 7.x Need REAL ANSWER NOW

You are using an obsolete PHP version

Your site is running on PHP 5.4.19 which has stopped receiving security updates since Thursday, 03 September 2015. Using this on a live site is dangerous: unpatched security issues can get your site hacked. Moreover, we can only guarantee support for obsolete versions of PHP after nine months since their end-of-life date. Therefore, support for your version of PHP may be dropped any time after Friday, 03 June 2016. We strongly advise you to ask your host to upgrade your site to PHP 5.6 or later.

 

WE NEED PHP UPDATED IMMEDIATELY!   There is no excuse for this Godaddy.  I have been a customer for the last decade and have brought many other clients to your hosting services.  If there is no response to this question with a DATE or ETA that I can provide my clients within 7 days, I will be forced to move ALL of my clients from your hosting services immediately. 

 

 Every other Hosting Provider has already updated to PHP 7 and have it available for their customers.  I will be moving to SiteGround in 7 days if there is no response from a Godaddy official.  No exceptions!  Either provide an answer, fix this, or lose 5 accounts!  Simple!

6 REPLIES 6

Re: PHP 7.x Need REAL ANSWER NOW

I was able to get v7.0 installed, but that was on a VPS.  They said you can get it on a Dedicated server too if you want.  Its just that upgrading on the shared hosting would have to upgrade all shared accounts on that server I would think and a lot of sites would break.  Just do it before you install a cPanel.

-
"Never press alt+f4 while working"
New

Re: PHP 7.x Need REAL ANSWER NOW

Unfortunately, 

 

These are all shared accounts and I will not purchase a VPS.  It is not my fault Godaddy provides outdated servers and are behind on updates.  It will be easier for me to move to another host that already offers updated servers.  Godaddy should have updated their shared hosting servers a long time ago.  They only offer 5.3 and 5.4 which are EOL

  Unsupported Branches

This page lists the end of life date for each unsupported branch of PHP. If you are using these releases, you are strongly urged to upgrade to a current version, as using older versions may expose you to security vulnerabilities and bugs that have been fixed in more recent versions of PHP.

 

Branch Date Last Release Notes

5.521 Jul 201610 months ago5.5.38A guide is available for migrating from PHP 5.5 to 5.6.
5.43 Sep 20151 year, 9 months ago5.4.45A guide is available for migrating from PHP 5.4 to 5.5.
5.314 Aug 20142 years, 9 months ago5.3.29A guide is available for migrating from PHP 5.3 to 5.4.


Currently Supported Versions Branch Initial Release Active Support Until Security Support Until

5.6 *28 Aug 20142 years, 9 months ago19 Jan 20174 months ago31 Dec 2018in 1 year, 6 months
7.03 Dec 20151 year, 6 months ago3 Dec 2017in 5 months3 Dec 2018in 1 year, 5 months
7.11 Dec 20166 months ago1 Dec 2018in 1 year, 5 months1 Dec 2019in 2 years, 5 months

Re: PHP 7.x Need REAL ANSWER NOW

We just checked our Godaddy Cpanel Shared hosting and PHP 7.1 is now available... hopefully we have some time before this version is outdated now.

Product Team
Product Team
Solution

Re: PHP 7.x Need REAL ANSWER NOW

@aaits

Exciting news to all GoDaddy cPanel users. Your account is now updated with the latest PHP 7.0 and 7.1! If you want to update, login to your cPanel dashboard. Then under the Software heading click “Select PHP version”. In the top left of the PHP selection page use the dropdown the PHP version you want and click set as current. You are now ready to go! But a heads-up before you update, I recommend you check you site for compatibility first. If you have any questions our customer support team is happy to help 24/7. Just call (480) 505-8877.

 - Paul Seguritan, cPanel Product Manager

Re: PHP 7.x Need REAL ANSWER NOW

It is 5/10/2019 and I do NOT see any 7.x PHP options on my Deluxe Unix shared account.  I select "programming languages" on the tools panel and I am only getting 5.x options.  Wordpress is requesting that sites be 7.x now.  If you guys say I have to upgrade, I am really looking to move my site to a host that will support it.

Community Manager
Community Manager

Re: PHP 7.x Need REAL ANSWER NOW

Hi @nanburke. Thanks for posting. I can understand your frustration. However, the answer here is to move to a cPanel hosting plan. As far as I know, there are no plans to add PHP 7 to our older Web Hosting platform. We are working on a migration tool to help users move from one platform to the other, but I'm not sure when that will be available. For now, you'd have to manually move the site. If you'd like information on how to do that, you can take a look at this article. We'd hate to see you go, but moving to cPanel really is the only option on our end at this point. 

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.