cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problem : Default php.ini loaded everytime.

Even if I have created a php.ini file in my public_html folder, still the default php.ini file is loaded. This problem creeped up day before yesterday and still exists. Before that, everything was perfect. I also did reset my hosting and only tested with the ini file to no avail.

7 REPLIES 7
Helper IV
Helper IV

Re: Problem : Default php.ini loaded everytime.

Hi, @cncgamezone,

Find the articles below. 

https://goo.gl/e81abo

 

The above articles will be helpful with shared hosting only. In case, If you're looking for VPS Solution. You should need to change the settings using Multi PHP.ini Editor. 

 

Re: Problem : Default php.ini loaded everytime.

 I have the same problem. PHP loaded configuration from the default /opt/alt/php71/etc/php.ini path. As per hosting lead, they will need to escalate a ticket for this to find a problem.

 

At this moment we can edit default php.ini from cPanel => Select PHP Version => Switch To PHP Options. But there is a limited options and it's not a solution. 

 

In the video from "manojkumarcdo" we can see, that after he created php.ini file in public_html folder - PHP Loaded Configuration File Path automatically changed to /public_html/php.ini. But in our case it stay default opt/alt/php71/etc/php.ini path.

Employee
Employee

Re: Problem : Default php.ini loaded everytime.

This is a known problem. Use the filename .user.ini instead, that will work.

Highlighted

Re: Problem : Default php.ini loaded everytime.

 BenWTF , .user.ini file do not let you modify all of the same settings as php.ini file.

Re: Problem : Default php.ini loaded everytime.

Worked out for me. Thanks.

Employee
Employee

Re: Problem : Default php.ini loaded everytime.

Good news!

 

As of yesterday, GoDaddy corrected the issue with php.ini loading. You should be able to change settings you weren't able to in .user.ini now.

Re: Problem : Default php.ini loaded everytime.

Hey, guys. Here's a solution considering everyone's input so far: 

1. If you've gone to PHP Settings and changed the memory limit that way, it will override whatever you have in your php.ini file (as of today, anyway). So click "reset" there and it will go to the default value of 128 M.

2. Now restart your server (on Godaddy shared CPanel, you can accomplish this by going to PHP Processes and then killing the processes.

3. Now look at your website's phpinfo.php file* (yourdomain@phpinfo.php) and you should see the master and local values for the memory_settings. And they should reflect what you've put in your php.ini file or user.ini file (whichever one you're using).

*If you don't know how to create a phpinfo.php file, google it. It's an easy file to create and keep in your root folder so you can see what's going on with your php settings. But you should delete it once you've checked yourdomain/phpinfo.php due to security issues.

 

Please let me know if you guys have any more questions or if I did a bad job explaining this; am happy to help.

 

Cheers.