Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Tuesday, August 3rd at 3pm PST / 6pm EST. Learn more
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
mb03
New

Why doesn't GoDaddy run the latest version of PHP?

mb03_0-1597157316000.png

 

This is what appears EVERY SINGLE TIME on the website for support...

Does anyone know why GoDaddy doesn't run the latest version of WP? It should have the capability of at the MINIMUM 7.4, and my upgraded GoDaddy Pro Linux cPanel is running on 7.3.17 ?!?!? My site goes down for 2 minutes at a time, MULTIPLE times PER DAY!!!! I've paid hundreds of dollars to a website developer to take a look at everything, and GoDaddy is typically the issue. This is so frustrating. I don't have time to spend an hour on the phone, and Chat NEVER LOADS! I cannot wait to migrate my site!

1 ACCEPTED SOLUTION
PL281
Super User IV

@mb03 

 

I am an end user like you. In regards to chat, I find it is best to use an incognito window - why I don't know, but that is a solution.

 

Regarding PHP 7.4 on a cPanel account. cPanel only released PHP 7.4 via EasyApache in the last 90 days or so. While GoDaddy does push out updates to cPanel / PHP Version, they do not push them out the day they become available - this is generally true of most shared hosting providers.

 

If you feel you have the need to have the latest versions of PHP / MySQL / other server software - I suggest looking into a VPS where you have root access and can update this as you wish. For example you could decide to run MySQL 8.0 if you wish - I warn against doing this as MySQL has added some additional reserved words which depending on your WordPress plugins might require tables to be re-named so they don't break.

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

3 REPLIES 3
PL281
Super User IV

@mb03 

 

I am an end user like you. In regards to chat, I find it is best to use an incognito window - why I don't know, but that is a solution.

 

Regarding PHP 7.4 on a cPanel account. cPanel only released PHP 7.4 via EasyApache in the last 90 days or so. While GoDaddy does push out updates to cPanel / PHP Version, they do not push them out the day they become available - this is generally true of most shared hosting providers.

 

If you feel you have the need to have the latest versions of PHP / MySQL / other server software - I suggest looking into a VPS where you have root access and can update this as you wish. For example you could decide to run MySQL 8.0 if you wish - I warn against doing this as MySQL has added some additional reserved words which depending on your WordPress plugins might require tables to be re-named so they don't break.

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

Thanks @PL281 : )

My concern for updating PHP is that my wp site has had a warning message for over 30 days that I'm not running the latest php version...and my site goes down every day multiple times for 2 mins at a time. I've had a local company that I use to help with website issues/developing take a look around at my site, they state it would sure help if GoDaddy updated the php. 

PL281
Super User IV

@mb03 

 

I just checked on one of my servers and see the 7.3.12 - and it recommends upgrading not that it is a critical issue.

 

I also check a cPanel account I have access to and PHP 7.4 is available in the PHP selector.

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community