cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

max_execution_time limits not being applied

Hey,

I have recently been struggling with a plugin on my wordpress site and after talking with my plugin dev this was the conclusion.

 

What my plugin dev suggested: Your php has two minutes execution time limit. Can you set it to 0 for unlimited time, it is in php.ini (or php settings in your cpanel) max_execution_time.  If you do not know what these things mean you can also contact to your provider and ask them to make it unlimited.

 

I have changed my own php.ini settings to 0 and the php linked to my hosting to 0 but neithet of these solutions have worked.  I also tried increasing them to 1200 but again no luck.


I have contacted Go Daddy via phone and chat but have had no luck in getting this to work.  So I am now turning here to the community as a last resort before needing to move.  Nothing against godaddy just really need this software working - could their be any potential limits on godaddy's end?  I upgraded from a shared hosting plan to a business hosting plan in hopes that would give me a solution but no luck.

 

Any additional information needed ill be happy to provide.

8 REPLIES 8
Helper VI
Helper VI

Re: max_execution_time limits not being applied

Hi @Plunder, welcome to the community! 🙂

Sorry to hear that 😕

I'd try to use a user.ini file, instead of php.ini.

 

Here are the contents for the user.ini:

 

memory_limit = 1024M
max_execution_time = 320
max_input_time = 240
post_max_size = 120M
max_input_vars = 2000
file_uploads = 6
max_file_uploads = 20
upload_max_filesize = 100M

Also, you may want to allow WordPress to use more memory, adding this line to your wp-config.php file:

define( 'WP_MAX_MEMORY_LIMIT', '1024M' );

If your hosting plan gives you less than 1024M of RAM, you should change the bold values.

 

 

Hope it helps!

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄

Re: max_execution_time limits not being applied

Hey @jpablo and thanks for the warm welcome,

I have made the user.ini file an placed it in my public_html root folder with the following setting:

memory_limit = 512M
max_execution_time = 0
max_input_time = 0
post_max_size = 120M
max_input_vars = 2000
file_uploads = 6
max_file_uploads = 20
upload_max_filesize = 100M

I have also configured my wp-config.php file with:

define( 'WP_MAX_MEMORY_LIMIT', '512M' );

I have experienced no changed in the plugin, it still only runs for 2 minuets before stopping the operation.  Since all my tinkering (and my devs too) began there has been no change in the operation of the plugin.  Reading up on some third party information I found some servers are configured to cut off PHP connections after a set time and there is nothing I can do on my end I hope this is not the case?...

Helper VI
Helper VI

Re: max_execution_time limits not being applied

You're welcome, @Plunder.

Sorry, I forgot to edit the reply. The file is supposed to be named .user.ini (there is a dot at the beginning).

 

Can you try renaming the file, and if you are in cpanel, you can kill all your php processes from the option PHP processes.

The .user.ini file takes around 5 minutes or so to get applied.

 

Let me know if it works!

 

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄

Re: max_execution_time limits not being applied

No luck @jpablo but thanks for trying.

After renaming to .user.ini I waited 5 minutes and ran it again and it didn't work.  I then waited 5 more minuets and killed all the php processes off.  Ran it again and still didn't work.

The operation still runs for the standard 2 minuets and then stops.

Helper VI
Helper VI

Re: max_execution_time limits not being applied

Sorry to hear that @Plunder

 

What's your plugin supposed to do?

 

 

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄

Re: max_execution_time limits not being applied

@jpablo A simple plugin but requires some PHP processes:

The plugin works with my suppliers spreadsheet or web detecting information about new releases and pre-orders and automatically updates them.

Helper VI
Helper VI

Re: max_execution_time limits not being applied

@Plunder maybe there's a limitation in the PHP functionality.

 

What hosting plan are you on?

 

 

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄

Re: max_execution_time limits not being applied

@jpablo

I using a Prime Business Hosting Plan at the moment - I just upgraded from shared to try and solve this issue.