Domain Manager is not opening

I Cant Access Domain i want to change my domain dns but domain manager is not opening  it stuck in this pageCapture.PNG


The same is happening for me. Domain Manager not opening. Cannot access nameservers.

Still hasn't been fixed? Encountering the same problem right now!

Still not fixed. Encountering the same problem all day right now after renewing my domain.

Happening for me yesterday and continuing through this morning - have tried several different web browsers (Chrome, Edge, IE11), it never loads.

Hi, also having the issue here.  I have spent time on the phone and emailing GoDaddy about this issue and the cause but they have done nothing so far.  I even recorded a screencast explaining the issue/cause and sent it through to GoDaddy - back on the 29th of April, and nobody has done anything to fix it. 


If you look in your browser's js console you will see that there is a problem with GoDaddy's AngularJS code:


Uncaught Error: [$injector:nomod] Module 'domainManager' is not available! You either misspelled the module name or forgot to load it. If registering a module ensure that you specify the dependencies as the second argument.
    at vendor.min.js:1
    at vendor.min.js:1
    at c (vendor.min.js:1)
    at Object.module (vendor.min.js:1)
    at dccLoadDeferred (dns?section=nameservers:124)



I have the same problem - Domain Manager shows it's loading ALL DAY, and there is no user support or e-mail address, only phone numbers that are not an option in Lithuania. Is this site a joke? I couldn't even transfer my domain because the domain manager just DOESN'T LOAD. smh

Ive had this same problem since yesterday. im freaking out

Hey Everyone,


I'm really sorry to hear about this recent experience you've all been encountering with accessing your Domain Manager interface. Seems like some of the issues described are varying, but many are often related to browser incompatibility issues.


When that occurs, it is strongly recommended that you start by clearing your browser cache and/or cookie settings first. You may also want to try using another internet browser if the issue persists. In more extreme cases the issue can sometimes be due to the local system or network you are connecting from. In those instances, the only way to be sure is to try connecting from a different device and/or network to confirm. 


If all of these suggestions have been followed and the error is continuing, then the last recourse is to contact our live support teams by phone or chat so additional information can be gathered for investigation. 


CG - GoDaddy | Community Moderator
24/7 support available at

View solution in original post

my domain managing page is not open , it show retry....

Community Manager

Hi @monu138. Thanks for being part of GoDaddy Community! I do see that there was a problem with our domain control panel around the time you posted this topic. That was resolved, but you might still be having issues due to browser caching. I'd suggest first clearing your browser's cache and cookies. If that doesn't help, then try using a cacheless browsing window (FireFox private window, Chrome incognito, etc.), then an entirely different browser. If that also doesn't work, you'll want to try to connect with support. 


JesseW - GoDaddy | Community Manager | 24/7 support available at | Remember to choose a solution and give kudos.