Go Daddy recently responded on another post: https://www.godaddy.com/community/Managing-WordPress/Managed-WordPress-Memory-Settings/td-p/20347

They confirmed it is in fact a Go Daddy issue with caching. In the response he says they are working on it.