• GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Highlighted
    New

    CDN Blocking Web fonts

    I'm building a website on a Managed WordPress staging site. When the CDN is enabled the web fonts are blocked and return this error in Chrome  "...has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource."  Is there a way to adjust the headers to allow these resouces to be served from the CDN?

    4 REPLIES 4
    Highlighted
    Super User III
    Super User III

    Re: CDN Blocking Web fonts

    @Steph3 

     

    What is your URL - I have many sites and haven't seen this specific issue.



    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    Highlighted
    New

    Re: CDN Blocking Web fonts

    Thanks for the response.

    You can view the issue here http://8kh.8e1.myftpupload.com/facility-rental/ when viewed in Chrome and Firefox. 

     

    Highlighted
    Super User III
    Super User III

    Re: CDN Blocking Web fonts

    @Steph3 

     

    Here is something with the EXACT SAME ISSUE - https://kriesi.at/support/topic/cors-font-errors-in-firefox/

     

    The temporary issue is to disable the CDN 

     

    Here is a suggestion from Divi with the same issue - add this to the .htaccess file

    <IfModule mod_headers.c>
    <FilesMatch "\.(svg|ttf|otf|eot|woff|woff2)$">
    Header set Access-Control-Allow-Origin "*"
    </FilesMatch>
    </IfModule>


    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    Highlighted
    New

    Re: CDN Blocking Web fonts

    Thank you for the suggestion. I tried the .htaccess option and a couple of other variations. It didn't work. 

     I have disabled the CDN while I look for another solution.