• GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    Getting Started

    PHP 7.3 on managed Wordpress

    I have a client with a site on Managed Wordpress. The site is currently running PHP 7.2 but is now getting the following message in Wordpress:

    WordPress has detected that your site is running on an insecure version of PHP.

     

    In the managed hosting settings I see where I can change the version, but the latest is 7.2. When will 7.3 be made available?

    1 ACCEPTED SOLUTION

    @LightCubed 

     

    I had this today - I had to clear the cache and refresh the dashboard and the alert went away

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    View solution in original post

    8 REPLIES 8
    Super User IV

    @LightCubed 

     

    I had this on a site last week - the solution was to toggle the PHP version in the Hosting Dashboard - for some reason WordPress was picking up the lower (older) version of PHP

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    Thank you for the reply. Tried that and it did not work. The Managed Wordpress settings only go up to 7.2 and 7.3 is current so that is likely why Wordpress is complaining.

    @LightCubed 

     

    You shouldn't have the error on 7.2 or 7.3 

    I would add the site into prosites.godaddy.com and see what it reports back as the PHP version - i'm guessing it may say 5.6 - hence the reason I said the try to toggle it to the older version and then back.

     

    If it still reports the same way after the toggle - I would give GoDaddy support a call (not chat) and ask them to take a look at it.

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    phpInfo() shows 

     

    PHP Version 7.2.15

    @LightCubed 

    What happens if you go to Tools -> Site Health -> Info -> Server - which should show the PHP version as I'm not getting the alert on any of my sites (and I was previously)

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    Don't see that exact path in Prosites, but if I go to More Tools -> System Info I see

     

    Server OSLinux (or compatible)
    WordPress version 5.2.4
    Worker version 4.9.1
    PHP version 7.2.15
    • Site IP xx.xx.xx.xx (hidden by me)
    • Processor architecture64bit
    • Languageen_US
    • WordPress timezoneAmerica/Los_Angeles
    • MySQL CLI accessOn
    • MySQL version5.6.32
    • MySQL DumpOn
    • Zip CLI accessOn
    • CURLOn
    • Unzip CLI accessOn
    • Safe modeOff
    • PHP execution time1,800 s
    • PHP memory limit256 MB
    • Root folder/var/www/
    • Max post size100 MB
    • Max upload size100 MB

    @LightCubed 

     

    I had this today - I had to clear the cache and refresh the dashboard and the alert went away

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    View solution in original post

    Yep, logged in today and it was gone.