cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
eddyg519
New

files uploaded are forbidden 403

Ive been trying to create a subdirectory in public_html.  i basically just have a index.html saying coming soon. I want to share a pdf file with some co workers and nothing seems to be showing up. i just got off the phone with a tech and he said i have to define the file in a .php (i previously had wordpress). Ive deleted everything on this account and i still cant access subdirectories even if they are chmod 777 it wont seem to let me in. 

 

the tech also said its been like this since day one.  i use to build websites professionally about ten years ago and i never had to define anything. files in public_html should be displayed should it not? i have a feeling this is something to do with godaddys hosting account ?  cheers 

1 ACCEPTED SOLUTION

ok that seemed to work. ive been using the cpanel upload script to upload. i never recall having to make an htaccess file to be able to index the folder. thanks for your help. 

View solution in original post

3 REPLIES 3
JHasselbring
Helper VI

I'm a bit lost... Did you upload the file via ftp/sftp or via php script?

Some webservers also prevent directory indexing by default. Take a look into .htacccess

Basically, create a file in your puBlic_html, name it .htaccess, type in "Options +Indexes" no quotes, save and try again
~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com

ok that seemed to work. ive been using the cpanel upload script to upload. i never recall having to make an htaccess file to be able to index the folder. thanks for your help. 

View solution in original post

The thing about development is that technology grows over time. Almost everyday, more and more bugs are being found and security features are being implemented. As a developer, we need to stay current to be relevant. Anyway, I'm glad I can help.
~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com