cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

website not showing using www but shows without it

thank you all for any help renderedSmiley Happy

 

my site www.cars.bt does not show but when typed as cars.bt it appears, any idea?

 

i created a cname with www pointing to my ip but it didn't help, i was then adviced to change the www from a cname to an A record and point it to my ip, this is not working too. pls check attachment.

 

 

1 REPLY 1
Helper V
Helper V

Re: website not showing using www but shows without it

I did some checking and the www record for your domain does not exist.

First I checked to see what your Nameservers are set to.

 dig NS cars.bt

; <<>> DiG 9.10.4-P2-RedHat-9.10.4-1.P2.fc24 <<>> NS cars.bt
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 12963
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;cars.bt.                       IN      NS

;; ANSWER SECTION:
cars.bt.                3599    IN      NS      mns02.domaincontrol.com.
cars.bt.                3599    IN      NS      mns01.domaincontrol.com.

;; Query time: 96 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Wed Sep 07 08:24:12 MST 2016
;; MSG SIZE  rcvd: 93

Next I checked for any records.

dig any www.cars.bt

; <<>> DiG 9.10.4-P2-RedHat-9.10.4-1.P2.fc24 <<>> any www.cars.bt
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47405
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;www.cars.bt. IN ANY

;; ANSWER SECTION:
www.cars.bt. 3599 IN NS mns01.domaincontrol.com.
www.cars.bt. 3599 IN NS mns02.domaincontrol.com.
www.cars.bt. 599 IN SOA mns01.domaincontrol.com. dns.jomax.net. 2016090300 28800 7200 604800 600

;; Query time: 76 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Wed Sep 07 08:30:15 MST 2016
;; MSG SIZE rcvd: 146

This tells me there is no A or CNAME record for www

When I do a record check for cars.bt I get a response for the A and MX record.

 dig any cars.bt

; <<>> DiG 9.10.4-P2-RedHat-9.10.4-1.P2.fc24 <<>> any cars.bt
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 7188
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;cars.bt.                       IN      ANY

;; ANSWER SECTION:
cars.bt.                1799    IN      A       182.50.154.39
cars.bt.                3599    IN      NS      mns01.domaincontrol.com.
cars.bt.                3599    IN      NS      mns02.domaincontrol.com.
cars.bt.                599     IN      SOA     mns01.domaincontrol.com. dns.jomax.net. 2016090614 28800 7200 604800 600
cars.bt.                3599    IN      MX      10 www.cars.bt.

;; Query time: 79 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Wed Sep 07 08:30:33 MST 2016
;; MSG SIZE  rcvd: 178

as far as accessing your site only A and CNAME records are used.

 

I would recommend you delete the www record from your DNS Control panel and then add it back as a CNAME pointing to cars.bt

once complete you can use the following command to check your domains nameserver for the www record. if you get a result then everything should be good after the DNS Propagation completes. May take 24 to 48 hours for Propagation to complete.

nslookup www.cars.bt 208.109.255.31

if after adding the record back and you get the following then you will need to contact godaddy.

 nslookup www.cars.bt 208.109.255.31
Server:         208.109.255.31
Address:        208.109.255.31#53

*** Can't find www.cars.bt: No answer

another option is to add an A record for * and have it point to 182.50.154.39

* is used as a wildcard and should allow www to point to your IP Address.