cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Code signing certificate doesn't work

Hi All.
I bought Code Signing Certificate and sign my MSI installer, but when I download installer from my  site and run it Windows SmartScreen shows "Unknown publisher" warning.

Here is manual for signing from GoDaddy: https://uk.godaddy.com/help/signtool-sign-windows-code-with-a-code-signing-certificate-4778

Also I have tried DigiCert tools for signing but I had the same result.
Here is screenshot from my signed application:
Certificate.png

Could anyone to help me?

Best regards,
Denis.

6 REPLIES 6
Employee
Employee

Re: Code signing certificate doesn't work

Denis,  I am with the SSL team and have been trying to reach out to you on this subject. I believe the problem resides not with the cert itself, but rather the sighing procedure. I am here to help you!  Would it be possible for you to send me a /v "verbose" execution of the signing process as specified in the MS documentation?  https://msdn.microsoft.com/en-us/library/windows/desktop/aa387764(v=vs.85).aspx  It would help in describing your current issue and I can direct you to some additional information. Please send it to dreynolds at godaddy.com.  Thanks!

Daymion

Re: Code signing certificate doesn't work

Hi!

Actually I have the same problem with my Code signing certificate / recognizing publisher.

I tried my certificate with signtool sign .. and  then with signtool verify on command prompt and it says that certificate is verified.

 

When I run publish and check properties of ClickOnce applications setup.exe it shows information about signer... but when I run application it self, it still shows Unknown publisher.

 

Sadly, but 2 different godaddy.com support team members could not suggest nothing better that just rekey (which I did without success) or just "check issue on your end" but not being able to specify what I should check on "my end".

 

I hope you are able to help me with this problem... (I also am sending thins information to the mail you provided, since it is really complicated to find anyone on godaddy.com that could help)

Re: Code signing certificate doesn't work

Hi, Denis!

 

Did you solve your problem with code signing /recognizing publisher name?

Could you share what was the problem in your case?

 

Thanks!

Best regards,

Uldis

Re: Code signing certificate doesn't work

Could not sen you an email...

550 5.4.1 [dreynolds@godaddy.com]: Recipient address rejected: Access denied

New

Re: Code signing certificate doesn't work

Did you solve your problem ?Could you share what was the problem in your case?

 

Thanks!

Best regards

Re: Code signing certificate doesn't work

No, I have not yet solved this problem.

I have a suspicion, that Visual Studio / signtool does not like that issuer
name contains quotes, because previously I had godaddy code signing
certificate with issuer name without quotes, but after the rekey issuer
name was changed and quotes added (I don't get what was the reason to do
this change...) and with this new certificate I have this problem with
unknown publisher