Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Wednesday, July 28th at 3pm PST / 6pm EST. Learn more
  • GoDaddy Community
  • VPS & Dedicated Servers
  • VPS & Dedicated Servers

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    sgdhande
    New

    Go Daddy Firewall setup

    I have purchased one VPS. I am trying to run one postfix mail server. I already opened Port 25 (Postfix Port) in this VPS, ufw is the software for firewall.  It seems port 25 is not open. Please explain. If you can provide the list of default ports open for a Linux Ubuntu VPS.

    While trying to check it it says

    # telnet 208.109.9.18 25
    Trying 208.109.9.18...
    telnet: Unable to connect to remote host: Connection refused

     

    1 ACCEPTED SOLUTION
    febb
    New

    @sgdhande I was there as well.  Just bought a couple of VPS gen 4 servers.

    I did the same, telnet <my_public_ip> 25  ,  to no avail.

     

    You need to do several things things:

    First, install firewalld and configure it to open port 25 on the public IP interface.
    Then,  configure your MTA (I'm using postfix), and make sure it is listening to port 25 on that public IP interface.

    If any of those two action are not correctly setup. It will not work.

     

    And, for full email to correctly work,  of course you have to setup the MX records on the DNS setup for the domain(s) that will be receiving/sending email to/from your VPS server.

    And correctly setup all the MTA's configuration. 

     

    My smtp MTA is working now,  I can receive emails without any problem and send them from the VPS server,  as long as the firewall is turned OFF. 

    When I turn ON the firewall, I am not longer able to send emails from the VPS server.   The network interface (and thus the IP) that the MTA (postfix) is using gets changed and thus it no longer works.  Working on trying to find out how to fix this...

     

    Let me know if you need any help pointers on setting the smtp port of your server.

     

     

    View solution in original post

    1 REPLY 1
    febb
    New

    @sgdhande I was there as well.  Just bought a couple of VPS gen 4 servers.

    I did the same, telnet <my_public_ip> 25  ,  to no avail.

     

    You need to do several things things:

    First, install firewalld and configure it to open port 25 on the public IP interface.
    Then,  configure your MTA (I'm using postfix), and make sure it is listening to port 25 on that public IP interface.

    If any of those two action are not correctly setup. It will not work.

     

    And, for full email to correctly work,  of course you have to setup the MX records on the DNS setup for the domain(s) that will be receiving/sending email to/from your VPS server.

    And correctly setup all the MTA's configuration. 

     

    My smtp MTA is working now,  I can receive emails without any problem and send them from the VPS server,  as long as the firewall is turned OFF. 

    When I turn ON the firewall, I am not longer able to send emails from the VPS server.   The network interface (and thus the IP) that the MTA (postfix) is using gets changed and thus it no longer works.  Working on trying to find out how to fix this...

     

    Let me know if you need any help pointers on setting the smtp port of your server.

     

     

    View solution in original post