cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Need help on redirecting www. to non www.

Hi, 

 I designed a wedding invite that had the URL of the website printed as www.domain.webflow.io. and didn't realise that having the www in the URL will cause some issues accessing the website. You can only access the site via the naked URL. Doh.

 

Is there any way to forward the www.domain.webflow.io to a GoDaddy custom domain, even though the www.domain.webflow.io URL doesn't exist?

Or is there any way edit the actual 404 page and place a link to the proper page?

Any advice on this matter will be highly appreciated.

1 ACCEPTED SOLUTION

Hi

This is the correct way of solving a site that will not come up when www is used in the web address. It will redirect the www to the naked domain without the www in front of it.

 

Log into GoDaddy and go to your domains. Select the domain and select "Manage DNS". 

  • Select and copy your domains IP address from one of the other entries. It will be the only IP address listed, maybe multiple times.
  • Goto the bottom and select the add button and fill in the spaces as listed below:
  • Type = A
  • Host = www
  • Points To = The IP address you already copied
  • TTL = I usually change this to 1/2 hour to get it up and running faster
  • Click Save

Give it a few minutes and you will eventually see the site while using www.yoursite.com and it will automatically change it to yoursite.com without the www.

 

 

 

View solution in original post

14 REPLIES 14

I have a domain say abc.rocks. I can browes abc.rocks but I get error 404 when I try to browse www.abc.rocks.
I have added a CName with name:www pointing to @ , but without success. Any suggestions please.
Zeni

I have a domain say abc.rocks. I can browes abc.rocks but I get error 404 when I try to browse www.abc.rocks.
I have added a CName with name:www pointing to @ , but without success. Any suggestions please.
Zeni

Adding a CName under the DNS Zone File tab is the right way to go, I believe.  BUT for the www record, it should point to www.abc.rocks.  I'm not familiar with the technique of it pointing to @...

If that doesn't work, try deleting the www record, as it might be actually interfering with the redirect.

First of all please check your .htaccess file and is there any code to permanent redirection like redirec 301 or something? .Otherwise check your site url in database table and edit them with www.domain name .

Hi @Zeni241,

 

Try this is your htaccess file.

 

Hope this helps!

James

Not Just Pretty Sites, Pretty Doggone Smart Sites

Hey @JMPepper

 

Try what? The code didn't come through..

Hi @Sam_T,

Sorry about that!

 

# BEGIN GD-SSL
<IfModule mod_rewrite.c>
Options +FollowSymLinks
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteCond %{HTTP_USER_AGENT} ^(.+)$
RewriteCond %{SERVER_NAME} ^www\.pepperspartiestoo\.com$
RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
Header add Strict-Transport-Security "max-age=300"
</IfModule>
# END GD-SSL

 

Hope this helps,

James

Not Just Pretty Sites, Pretty Doggone Smart Sites

Hi Zeni241

Please follow this path it will definately solve your problem.

Home > Domains > Redirect 

and select redirect to www or without www radio button.

 

Cheers 🙂

Not seeing this option anymore...

I  had the same problem. My solution is transfer domain to namecheap

Helper VI

As long as they point to the same vHost

RewriteEngine on
RewriteCond %{HTTP_HOST} ^www\.example\.com [NC]
RewriteRule ^(.*)$ http://example.com/$1 [L,R=301]
~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com
New

Some dns setting can solve this problem. I purchased my domain www.earningbaba.com from Godaddy and I faced this problem but I resolve it myself. visit my domain it is working fine. see this it will help you 100%  Read it help mehttp://www.earningbaba.com/2017/03/solved-without-www-naked-domain-blogger.html

Abhikr,

 

Unfortunately i'm getting a 404 for your site.

 

Did anyone ever find a solution for this as Ive just started a new thread.

Hi

This is the correct way of solving a site that will not come up when www is used in the web address. It will redirect the www to the naked domain without the www in front of it.

 

Log into GoDaddy and go to your domains. Select the domain and select "Manage DNS". 

  • Select and copy your domains IP address from one of the other entries. It will be the only IP address listed, maybe multiple times.
  • Goto the bottom and select the add button and fill in the spaces as listed below:
  • Type = A
  • Host = www
  • Points To = The IP address you already copied
  • TTL = I usually change this to 1/2 hour to get it up and running faster
  • Click Save

Give it a few minutes and you will eventually see the site while using www.yoursite.com and it will automatically change it to yoursite.com without the www.

 

 

 

View solution in original post