cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
New

Wordpress Error on Plesk Hosting- open_basedir restriction

I have following error on my page footer Plesk hosting.. Same theme (bridge from theme forest) is working great on wordpress hosting plan.

 

Website is pet-toon.com

 

PHP Warning: file_exists(): open_basedir restriction in effect. File(/bridge45/wp-content/uploads/2014/05/title1.jpg) is not within the allowed path(s): (G:/PleskVhosts//amoureuropa.com\;C:\Windows\Temp\) in G:\PleskVhosts\amoureuropa.com\pet-toon.com\wp-content\themes\Bridge\title.php on line 30

 

Issues started when I added petition.com domain to Plesk deluxe. Any advices?

4 REPLIES 4
Helper IV Helper IV
Helper IV
Solution

Re: Wordpress Error on Plesk Hosting- open_basedir restriction

@viango - it looks like you are being blocked from opening the image file because it is outside the path of the script that is calling it. Try switching where you are accessing title1.jpg and see if that fixes the problem.

 

PHP open_basedir protection tweak is a Safe Mode security measure that prevents users from opening files or scripts located outside of their home directory with PHP, unless the folder has specifically excluded. PHP open_basedir setting if enabled, will ensure that all file operations to be limited to files under certain directory, and thus prevent php scripts for a particular user from accessing files in unauthorized user’s account.

 

Cheers!

Doc

 

 

Need some help with WordPress? Check out Site Doctor 911
Worry-Free WordPress Support - So You Can Focus On The Important Stuff
New

Re: Wordpress Error on Plesk Hosting- open_basedir restriction

Thanks, but definition of the issue didn't help me to fix the problem. Resolution of the problem was switching to FastCGI PHP handler 5.6.25.

Re: Wordpress Error on Plesk Hosting- open_basedir restriction

Have to edit "wp-config.php" and change allowed relative path.

Check this article: http://www.agentwp.com/open_basedir-restriction-in-effect-error-in-wordpress

 

New

Re: Wordpress Error on Plesk Hosting- open_basedir restriction

Thanks!.

I had the same problem and the 'Fast CGI' fixed it.