cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Wordpress theme upload error: "The link you followed has expired. Please try again."

No matter what theme I try to install (I've tried 3 different themes at this point) I get a message that says "The link you followed has expired. Please try again."  They are purchased themes and I have successfully installed them on other GoDaddy hosted wordpress sites.  

 

I've done google searches and support forum searches (on this forum and the theme forums) and can't find a solution.  I'm hoping someone can help 🙂

 

I am running WordPress version 4.9.5. 

php version 7.1 

This is the error page address: http://soulshine.yoga/wp-admin/update.php?action=upload-theme. 

I use Linux cPanel.

 

 

 

1 ACCEPTED SOLUTION

Make these changes in PHP Options to correct:

max_execution_time   180

memory_limit   512M or your highest available

post_max_size  32M

upload_max_filesize   64M

View solution in original post

12 REPLIES 12

I am getting the same error from past two days.  Have tried looking online but couldn't find anything useful.

 

Would be great if somebody could help.

I just switched my php version to 7.0 and the theme install worked once I did that.  Maybe that will work for you.  Perhaps my issue was a compatibility issue between php 7.1 and my theme.  

 

I will leave this thread up for others to offer in put too.

How did you alter your php version?

New

I have the same issue 😞

@swoodling,

@webloose,

@anshal,

 

Are you getting that error for all themes?, or certain ones...

What about plugins?, Are you able to install them successfully...

Looking forward to hear from you...

 

Regards,

 

Praveen Thomas

GoDaddy 24/7 Support www.x.co/247support
----->NEXIA

Hello,

 

This is my first theme install and the problem still persists. 

 

I tried installing with the PHP option and everything works just fine. 

I am having  the same problems with plugins over a certain size. So I am thinking there is some timeout setting that is relevant now that didn't used to be?

 

I was able to get around this by FTP'ing into the site and uploading the plugin but it was super annoying and took a lot longer because I decompressed it before I uploaded it.

 

Anyone find a fix?

Hi,

 

I had to do the same FTP process to get it to upload. (and yes I agree it is tedious) I am still having the same error uploading the theme the traditional way. 

 

Make these changes in PHP Options to correct:

max_execution_time   180

memory_limit   512M or your highest available

post_max_size  32M

upload_max_filesize   64M

View solution in original post

@tjoyce28,

I'm VERY new to wordpress and no nothing about making websites. I had a friend make this site for me and i figured out how to play with the theme. 

 

I got this error and now looking into the PHP Options file. Do i just copy and paste that in the code? Sorry for silly question! 

I FK LOVE YOU MAN!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

I was having the same issue, used your php settings fix, and it worked like a charm. Thank you SO much.