• GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    Highlighted

    Flush Cache doesn't work

    Hello,

    I'm using Managed Wordpress Hosting and I'm having caching issues when editing the css.

    Tried the Flush Cache option in the top bar menu under  'Managed Wordpress' but that doesn't help.

     

    Any solution?

     

    Thanks in advance

    2 ACCEPTED SOLUTIONS

    Accepted Solutions
    Highlighted
    Super User IV
    Super User IV
    Solution

    Re: Flush Cache doesn't work

    @DarkoNedelkovsk 

     

    I've seen this happen with some themes - the best thing to do is go to style sheet in the browser (not in editing mode) and add &nocache=1 to the end of the URL

     

    You may have to do ?nocache=1 if there aren't other variables...

    So style.css?&ver=5.2.2&nocache=1  or style.css?nocache=1

     

    That should refresh the stylesheet as well - it's a combination of server / client side caching

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    View solution in original post

    Highlighted
    Solution

    Re: Flush Cache doesn't work

    i just dealt with this for the past hour, so frustrating!  the nocache=1 would show the changes but the regular url would not. I had cleared my browser cache, tried everything.  Finally I realized it was the firewall cache.  Your account may not be set up that way but for anyone who's is, you go to Your Products, scroll down to Website Security and click Manage. Up top click Firewall, then Settings on the right. Next click the Performance tab. along the left menu in teal you will see a tab for Clear Cache. click that and then click the black Clear Cache button and that should do it.  hope this will help someone else dealing with this issue.

    View solution in original post

    4 REPLIES 4
    Highlighted
    Super User IV
    Super User IV
    Solution

    Re: Flush Cache doesn't work

    @DarkoNedelkovsk 

     

    I've seen this happen with some themes - the best thing to do is go to style sheet in the browser (not in editing mode) and add &nocache=1 to the end of the URL

     

    You may have to do ?nocache=1 if there aren't other variables...

    So style.css?&ver=5.2.2&nocache=1  or style.css?nocache=1

     

    That should refresh the stylesheet as well - it's a combination of server / client side caching

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    View solution in original post

    Highlighted

    Re: Flush Cache doesn't work

    Hi,

    Thanks for your reply.

    It worked only  the first time and now it doesn't work any more.

    I'm using Salient theme.

    There must be another way to flush cache and disable it, something like Dev Mode.
    I'm editing the css file and I really need to check the changes all the time.

    Highlighted
    Super User IV
    Super User IV

    Re: Flush Cache doesn't work

    @DarkoNedelkovsk 

     

    At this point there is no dev mode - I would also try an incognito window - I find i have this issue with the Lambda theme  and the skin/css

    I am a GoDaddy End User - Just Like You
    Check out my site! | I currently manage over 300 WordPress Websites
    * Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

    Once your issue is resolved,
    please be sure to come back and click accept for the solution

    Get Better Support on the Community Boards!
    Etiquette When Asking for Help from the Community

    Highlighted
    Solution

    Re: Flush Cache doesn't work

    i just dealt with this for the past hour, so frustrating!  the nocache=1 would show the changes but the regular url would not. I had cleared my browser cache, tried everything.  Finally I realized it was the firewall cache.  Your account may not be set up that way but for anyone who's is, you go to Your Products, scroll down to Website Security and click Manage. Up top click Firewall, then Settings on the right. Next click the Performance tab. along the left menu in teal you will see a tab for Clear Cache. click that and then click the black Clear Cache button and that should do it.  hope this will help someone else dealing with this issue.

    View solution in original post