cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
New

My domain name not resolving correctly, 6 random characters are being added to the path

My problem started yesterday (24/08/17). When I open a browser it is configured to my homepage hosted on my ISP and the name I have configured with godaddy resolves to the name my ISP gives me. This has worked fine for the past 8+ years. Now what is happening when I open a browser the resolved url now has extra characters, for example, there will be an added path like /TWedTZ on the end of the resolved url.

My homepage is a basic webpage with other url's, more like a bookmark page, nothing special at all. www.skozzyonline.com it should resolve to users.tpg.com.au/skozzy but often now those extra characters are added.

Where should I look to find out what is going on.

skozzy
1 ACCEPTED SOLUTION

Being very frustrated with GoDaddy, saying it was fixed and it was not. I decided to create a FIX. I use WordPress / PHP. In WordPress, the themes files there should be a 404.php file. Otherwise it will work in any 404 php script file. At the top of the file I have added a redirect script to remove the 5 random characters and the following slash. So the logic is, if it is already a 404 not found and the last 6 characters are the bad redirect (ex. 'aRkHv/'), remove the 6 bad characters and redirect again. It is not a perfect script, but it will work in 99% of cases. You may need to add some exceptions.

 

/* GoDaddy 404 Redirects FIX */
$currURL = $_SERVER['REQUEST_URI'];
$CheckRedirectError = substr($currURL, -6);
if (preg_match("/^[a-zA-Z]{5}\/$/",$CheckRedirectError)){
$protocol = (!empty($_SERVER['HTTPS']) && $_SERVER['HTTPS'] !== 'off' || $_SERVER['SERVER_PORT'] == 443) ? "https://" : "http://";
$redirectTo = str_replace($CheckRedirectError, '', $currURL);
header("HTTP/1.1 301 Moved Permanently");
header("Location: " . $protocol . $_SERVER['HTTP_HOST'] . $redirectTo);
exit();
}

I hope this helps some people.

View solution in original post

54 REPLIES 54

I setup domain forwarding to go to https://runsignup.com/Race/OH/Stow/SMFChoirQuartetRelay 

 

It works on my desktop machine and in the Samsung Browser on my Galaxy S4, but when I try it using Chrome on my Samsung Galaxy S4 it resolves to  https://runsignup.com/Race/OH/Stow/SMFChoirQuartetRelay/LpgLZ/UbINZ/ .  Note:  if I clear browsing history and try again it doesn't work and the "random" characters at the end change to different characters.

 

 

 

 

Same problem here, It's been a while since I started using http://catalogo.vapeclubsv.com to redirect to https://www.facebook.com/notes/vape-club-sv/catálogo-de-sabores-e-liquid-vape-club-sv/18884193447350..., but lately I've noticed it resolves to https://www.facebook.com/notes/vape-club-sv/catálogo-de-sabores-e-liquid-vape-club-sv/18884193447350..., which as you can tell, it adds QWpnZ/ToUUZ/WUdMZ/ at the end of the URL.
I'm using a Nexus 6 with Android 7.1.1. Firefox works perfect on same device.

Same problem here.  Getting stings like "/mdxoz" and "/zchsz" added to the end of the URL I am forwarding to.  Started about a week ago.

Has anyone reported this to GoDaddy support?

BTW this does not happen every time.  Sometimes the forwarded domain loads fine but I get the junk string about 30 - 40% of the time.  This is true on every browser that I have tested including:

Android Chrome

Safari - iOS

Safari - Mac

Chrome - Mac

Firefox - Mac

Wow -- I thought I was the only person experiencing this issue.  I spoke with GoDaddy support and they say it's an issue on my server end.  Just for fun I changed the name servers to my host and disabled forwarding.  Surprise, the issues are no longer there -- no funny characters being added to the end of my domain.  It only happens when I do forwarding of domain through GoDaddy (with or without masking, doesn't matter).  I tried doing direct links in the forward and not leaving ending slashes, but it still bugs out randomly.

Experiencing this issue too. I can confirm that it is definitely an issue on GoDaddy's side. This only occurs when I am using their forwarding.

 

I've spent several hours researching about this and apparently this has been an issue for GoDaddy for years and they continue to deny that it is an issue on their end, even though it's obvious that they are wrong.

 

Honestly this is absolutely unacceptable and we will be switching to another registrar. I suggest everyone reading this to do the same.

Brutal.  I have over 400 domains with them currently.  This is going to be a nightmare transfer.

I did not know about this community page and did a report to GoDaddy via chat last week. Their support person did not even point me to this page! How do we escalate this? (Some of you seem to think that migrating out of GoDaddy is the only way?) 

I found a temporary solution until GoDaddy resolves this issue. Won't work in all use cases, but works to forward the URL to a new domain without preserving any query parameters, while preventing a 404.

 

Append a query string to the forwarded URL in GoDaddy's forwarding setting. Example:

 

https://destinationdomain.com/?source=forward

 

Because GoDaddy's URL slug is appended sporadically, it doesn't always show up. So visiting the source domain in these circumstances presented the following results for me:

 

https://source.com/

https://destinationdomain.com/?source=forward

 

https://source.com/

https://destinationdomain.com/?source=forward%2FKjbKZ%2F

(GoDaddy's added URL slug would have been /KjbKZ/ in the above result)

 

https://source.com/?test=true

https://destinationdomain.com/?source=forward%2F%3Ftest%3Dtrue

(GET query parameter is not preserved)

 

Hope this helps someone. To any GoDaddy representatives who may read this: this seems to have been happening for weeks now. Why?

Yep. Same problem for me. Naked URL works fine, distimor.org  , but www.distimor.org adds a random string at the end of the address. Then the page is not found.

 

Would love a solution because the link on the google search results is not working. 

We started seeing this on forwarded domains a few days ago. We've contacted GoDaddy support 4 times now. Even provided them with a video showing the random characters that they requested. Even with proof, they just fall back to the standard troubleshooting stuff that first line support people use. The latest call said it's a caching issue and wait 24 hours!   Yeah, like caching creates random 5 letter strings and never the same one twice.

 

I purchased a domain from NameCheap and forwarded to the page, just like the Godaddy domain is set up. We've done extensive testing over the last 12 hours and the NameCheap forwarded domain hasn't failed once.

 

I've been a Godaddy customer for over 20 years and have a pile of domains. I don't appreciate the tone GoDaddy support is giving us. One call the support rep was rude. They are saying it is our problem.

If you search this issue, you'll see that it's an issue that has existed for years with GoDaddy.  I've never found a resolution for this problem. Why is GoDaddy trying to hide this problem??

Hi this is about the solution involving namecheap. Thanks for posting it. 

 

I wanted to see if I can try a temporary fix by using namecheap DNS service to the do forward and keep the domain registered at GoDaddy for the moment. Do you think that will work? In your example you are saying you bought a new domain on namecheap and that's confusing. 

Hi we're getting a similar issue. In the last couple days random characters have been added to the middle of the url. As an example mysite.com/page/32 becomes mysite.com/RDFTR/page/32 which then creates a 404. 

 

It's only happening sporadically which makes it even more frustrating.

This is a screen shot from firefox's developer tools when a forwarded domain fails.  Doesn't this show the DNS resolution is generating these random characters?   I sent this to GoDaddy support and they said their developers refused to look at it (I kid you not!).  They are standing firm that this issue is my problem. They now have me contacting my ISP because tracert showed a timeout on one hop, even though I told them that I have multiple clients experiencing this in different areas (and different ISPs).

8-30-2017 6-02-58 PM.jpg

New

I contected support too, the guy I spoke to said he loaded my webpage on chrome and firefox and he didnt see a problem. Asked me to contact my ISP as he believes it is their problem.

So I called my ISP, spoke to a tech, and also another via the web support desk. They tested a few things and said it is not coming from their end and it is a GoDaddy problem. I ask the ISP to not stop there and if someone could test it a few times each day, so far no response but still waiting.

So the are blaming each other.

The problem is still going on, like others have said in the replies, its not all the time, it seems random.

I went next door who have a different ISP and tried my URL on their laptop, all was fine, then rebooted the laptop and the extra characters on the forwarded url were there. Closed the browser and opened it and was normal. So it is random for sure.

Anyhow at the moment it is 5 random characters, mixed of upper and lower case. I thought it was 6 extra at first.

It is annoying but only GoDaddy can find out what is going on.

I have tried many browsers, different OS's and different PC including Virtual OS's from Windows, Linux, iOS, Android (like phones tablets etc) and all get the same thing from time to time.

skozzy

Hello everyone here, I was facing the same issue and haven't noticed before a huge drop in my website traffic. Even I contacted godaddy many time to look into the issue, but they replied same as did to others.

 

I don't know what the exact problem is, but I have found a workaround. You need to make small modifications in your .htaccess file linked with the domain.

 

Add lines at the top of your .htaccess file.

RewriteEngine On
RewriteRule ^[a-zA-Z]{5}/(.*)$ $1 [R=301,L]

Note change the line {5} to {6} if you are getting 6 random characters.

 

Read more - http://gold-thiolate.com/2013/godaddy-random-302-redirect/

I have a similar problem (http://example.com/KhMLZ/).  I tried your solution for the .htaccess file but it doesn't seem to be working for me.  I still have the forwarding problem.  Can you give any other suggestions or tweaks to the .htaccess file solution? Thanks

I worked around this problem by setting my redirect to "www.domain.com/?x="

 

which resulted in a 302 Found to:

Location: https://www.domain.com/?x=/NfiPZ/ReoaZ/

 

which works for my needs.

See the following URL for a whole string of other people who are having the same problem that GoDaddy is refusing to acknowledge and fix.
https://www.godaddy.com/community/Managing-Domains/Domain-forwarding-working-intermittently-http-to-...

 

Thanks to ribbles above and Daniele in this other thread for a quick temporary workaround. "So how about redirecting to http://www.yourdomain.com/? In this case, when godaddy adds the extra characters to the URL, they become parameters and don't cause a 404."

 

Adding the question mark to the end of your forwarding URL works.

I discovered that this problem is not only a GoDaddy forwarding problem, but also a problem with GoDaddy hosted domains.  I have a domain that is registered and hosted with GoDaddy.  Oftentimes when I refresh my GoDaddy hosted webpage, it automatically adds the random letters. 

 

GoDaddy appears to be very hush, hush to the customers about what is causing the problem. I am going to take a wild guess and say that these problems are a result of GoDaddy's new Domain Connect 2.0 in which we now have a new ugly CNAME in our DNS managers:

 

CNAME     _domainconnect     _domainconnect.ss.domaincontrol.com

 

From reading this article below, it seems their ultimate purpose is to expand their sales by putting every domain to use (nevermind all the grief that it causing their customers). 

 

https://engineering.godaddy.com/seamlessly-connecting-domains-services-domain-connect-2-0/