cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
New

How to change my PHP limit--max_input_vars

Warning! Your PHP configuration limits the maximum number of fields allowed in a form: 1000 for max_input_vars.
Please ask your hosting provider to increase the this limit to 1396 at least or edit the translation file manually.

 

i want change limit to 5000 ???

25 REPLIES 25
Helper I

Re: max_input_vars

Hi,

 

That limit is quite huge, I doubt if Godaddy team can increase that or not.

You can add one line in your .htaccess file

 

php_value max_input_vars 6000
php_value suhosin.post.max_vars 6000
php_value suhosin.request.max_vars 6000

The first one is required, but I have given other two as well. This will also come in future 🙂
But this will work, ONLY if Godaddy has enabled the above settings for user account.

Or else, you need to contact them via contact number and tell them to increase for you.

New

Re: max_input_vars

i got same problem, after wanted to translate store, Warning! Your PHP configuration limits the maximum number of fields allowed in a form
1000 for max_input_vars.
Please ask your hosting provider to increase this limit to 2046 at least, or you will have to edit the translation files. but I actually bought most all stuff already, how to increase this thing? its free, ? paid? cant find anything  about it

New

Re: How to change my PHP limit--max_input_vars

I discovered this talking with GoDaddy support last year:

 

1) The PHP.INI file is not accessible for update through the c-Panel file manager
2) Create or edit a file called /public_html/.user.ini (in my installation this is the root directory location of my hosted web site files)
3) Add revised PHP parameters to this file (Example:  max_input_vars = 5000 on a single line)

 

As a note, this worked great until about a week ago - maybe a new version of PHP was installed on my server or my site was moved to another server.  However, I re-created the ".user.ini" file today and it works perfectly again.

 

Re: How to change my PHP limit--max_input_vars

Dear Horst thank you for your effort.

 

I did as you advised but it didn't worked for me!. Could you imagine any reason why could be or how I could fix it? (by the way, some help from GoDaddy would be appreciated )

 

What version of PHP you are using?

Mine is PHP 5.6

I did created /public_html/.user.ini file and in that file I have only one line as "max_input_vars = 5000"

 

Kind Regards

 

Edit:

After reviewing some posts I'd discovered that since I'm using cPanel hosting I could create /public_html/php.in file. It's worked with the same "max_input_vars = 5000" line.

 

So it's done thank you!

Re: max_input_vars

Dear Sagar,

 

I'd tried as you advised but then my Wordpress has been crushed. So I'd to delete it 😞

 

Edit:

I did solved it as I wrote above.

 

Re: How to change my PHP limit--max_input_vars

I am going to share my experience using godaddy with you and also give you a solution to this issue.

 

I have been with godaddy for over 5 years and there really are some good tech leads working there! however when you call them and fall on the new guys they are very reluctant to help and usually just go with the script! 

i had this same issue and i called 24 hours ago and it was fixed, i uninstalled prestashop 1.6+ and reinstalled a fresh one plus theme and called and was told i needed to pay $29.99 for something someone did in 5 seconds for me 24 hours prior for free.

 

anyway after 3 phone calls and alot of fustrations one godaddy techie solved my issue ( BLESS HIM)

 

on the shared hosting cpanel with godaddy the file you need is a .user.ini file 

 

the values required ( MAX) are

memory_limit = 1G
max_execution_time = 300
max_input_time = 300
post_max_size = 1G
max_input_vars = 10000
file_uploads = -1
max_file_uploads = 35
upload_max_filesize = 1G

 

I hope this helps!!

Helper IV
Helper IV
Solution

Re: How to change my PHP limit--max_input_vars

Hi @naif @LinaL @Fullfol

 

I have attached a video File below. Easy to understand. Just follow the tutorials below and increase your default PHP Limit.

https://youtu.be/tdUlIkZcOe0

 

 Thank You.

Re: How to change my PHP limit--max_input_vars

Can you give instructions on how to do this with Managed Wordpress? 

I added a .user.ini file with the following contents:

 

memory_limit = 96M

max_input_vars = 5000

 

But nothing seems to change. 

Helper IV
Helper IV

Re: How to change my PHP limit--max_input_vars

Hi @alfonso1

Check this out.

https://youtu.be/poXSRVnRieY

 

Thank You.

Re: How to change my PHP limit--max_input_vars

Thanks man. This is the only thing that worked for me.

Re: How to change my PHP limit--max_input_vars

 

Re: How to change my PHP limit--max_input_vars

Hi I got the same problem. By looking at the video, I realised that I do not have any user.ini file. How can I create it?

Employee
Employee

Re: How to change my PHP limit--max_input_vars

Hello @Elmakiko!

 

Thank you for posting. Have you tried using your favorite search engine to find instructions on building this file? I was able to find this guide on creating a user.ini file

 

Heather - GoDaddy | Community Moderator
24/7 support available at x.co/247support

Re: How to change my PHP limit--max_input_vars

Thanks a Lot

Rockstar I Rockstar I
Rockstar I

Re: How to change my PHP limit--max_input_vars

Hi All,

 

Excellent info in this thread.  One point that has not been mentioned.  After making changes to your .user.ini file be sure to clear cache on both your server AND browser.  Wait about 15 minutes before checking the settings.  Sometimes you'll make the changes, but won't see them until cache is completely cleared.

 

Hope this helps,

James

Not Just Pretty Sites, Pretty Doggone Smart Sites

Re: How to change my PHP limit--max_input_vars

I can't get the max_input_vars to change no matter what I do. I tried everything on this page and it won't change. All of the other values are changed but not this one. I'm at a total loss.

Re: How to change my PHP limit--max_input_vars


@cvalery82 wrote:

I am going to share my experience using godaddy with you and also give you a solution to this issue.

 

I have been with godaddy for over 5 years and there really are some good tech leads working there! however when you call them and fall on the new guys they are very reluctant to help and usually just go with the script! 

i had this same issue and i called 24 hours ago and it was fixed, i uninstalled prestashop 1.6+ and reinstalled a fresh one plus theme and called and was told i needed to pay $29.99 for something someone did in 5 seconds for me 24 hours prior for free.

 

anyway after 3 phone calls and alot of fustrations one godaddy techie solved my issue ( BLESS HIM)

 

on the shared hosting cpanel with godaddy the file you need is a .user.ini file 

 

the values required ( MAX) are

memory_limit = 1G
max_execution_time = 300
max_input_time = 300
post_max_size = 1G
max_input_vars = 10000
file_uploads = -1
max_file_uploads = 35
upload_max_filesize = 1G

 

I hope this helps!!


 

Thanks a lot, It works for me!

PHP version : 7.1

Re: How to change my PHP limit--max_input_vars

Smiley Very HappyHeart

Re: How to change my PHP limit--max_input_vars

This worked perfect! Thank you

Solution

Re: How to change my PHP limit--max_input_vars

This video will show you how to change:

 

https://www.youtube.com/watch?v=XtdG5i2nPuI

 

create a .user.ini file

 

code edit with this statement and save:    max_input_vars = 5000

 

 

 

Re: How to change my PHP limit--max_input_vars

Re: How to change my PHP limit--max_input_vars

I have gone through this question and answer briefly. I have created a file in the root directory  /public_html/.user.ini file with the above parameters.

When i run phpinfo, discovered that the user.ini file is not loading,rather it is the shared server setting that is loading. What do i do to ensure it loads my ini file instead of the default.

2. Also, Should the ini file be located in the root directory or in each sub domain directory?

Rockstar I Rockstar I
Rockstar I

Re: How to change my PHP limit--max_input_vars

Hi @kingsadave,

 

As you are checking your changes, have you cleared cache on both the browser and server side?Sometimes it may take 15 minutes or more to show any .ini changes. 

 

Are you still on an older cPanel plan?  If so, you might want to consider moving to the new cPanel plans.  The interface for managing your php settings is much cleaner and easier often resulting in little or no need to edit the .ini files manually.  

 

When you ask about subdomains, are you going to be running wordpress?  If so, are you going to be running it as a multi-site installation?  These question impact how you distribute resources.  Also, if you are not using WP, you will need to parcel out your resources across subdomains via ini files.  Often times if you are doing this many of the defaults work fine.  

 

I recently upgraded an old to a new and was quite pleased.  I ended upgrading to full business enterprise plan and came up with a pretty good WP installation using add-on domains.

 

Hope this helps,

James

Not Just Pretty Sites, Pretty Doggone Smart Sites

Re: How to change my PHP limit--max_input_vars

Thanks. I have been able to create the ini file in the sub directory  and inserted setting as desired for the input vars and it is working fine now

Re: How to change my PHP limit--max_input_vars

This is not possible under Managed WP.  They have a master limit of 1000.  Support would not budge, so, if you're up against this issue, you either need to change your plan or find another host.