Skip to main content
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to Login to WordPress and they are not sending reset password email

Hello all!,


I have spend the past 4 days trying to login to my WordPress and it says my login is invalid. I can login on my laptop because it "remembers" my login, but not on my other computer. It says it will send a reset password email but I tried that 8 times now and still am not getting an email from WP.

When I am on my laptop it shows my email so I know it is the right one, but when I try the reset password with my email as the username, it says it is incorrect? 


I am at a loss of what to do. 

Super User I

If you are using Managed WordPress, you can get to the Dashboard by logging into your GoDaddy account, then choosing the hosting, then "manage"... then go to the Users section and reset the password.


I have not seen it where the system will not send the reset email -- but here's a question: is the email on the same domain as the website, or is it a separate email (gmail, whatever)? 


The reset should work whether you enter the username or the email associated with it (they are linked, and if you enter the user name, it will send to that email address anyway).



I have used my godaddy account to log in to wordpress but it says wrong user name or password and no email i have tried possible is working   locked out

Helper IV

Thank goodness for auto save! Since you can login with your laptop, why don't you log in and change your password? Then  save your username and password someplace in case you run into the same problem again.


Good luck!




Need some help with WordPress? Check out Site Doctor 911
Worry-Free WordPress Support - So You Can Focus On The Important Stuff

I am having same problem. Can't access through wordpress, only godaddy, and not with email and not with user name now either. each time I go in a reset my password but it never "sticks" and it reverts back to a randomly generated one. 


I also notice the ip address connected in wordpress is different than my domain address. Could this have something to do with it?