cancel
Showing results for 
Search instead for 
Did you mean: 
New

Website is down...any ideas what these error codes mean?

Anyone any idea what is going on with my website? Its a sports club and the website is no longer displaying and this is the error message -


Warning: ksort() expects parameter 1 to be array, object given in /home/content/p3pnexwpnas02_data01/29/2057529/html/wp-content/plugins/bbpress/includes/core/template-functions.php on line 316

Warning: Cannot modify header information - headers already sent by (output started at /home/content/p3pnexwpnas02_data01/29/2057529/html/wp-content/plugins/bbpress/includes/core/template-functions.php:316) in /home/content/p3pnexwpnas02_data01/29/2057529/html/wp-includes/pluggable.php on line 1179

1 REPLY 1
Advocate VI Advocate VI
Advocate VI

Re: Website is down...any ideas what these error codes mean?

Did this just show up with the upgrade to WordPress 4.7? A likely possibility is that one or more plug-ins is now incompatible with Core files, or with another plug-in. This is easily verified, by confirming that disabling one or more plug-ins restores the site.

 

So one approach would be to disable all of the plug-ins from the back-end, and see if the site is up. I realize that it may not look quite right, as some of the plug-ins may control what it looks like. But if the site comes back up, then you can try enabling plug-ins one at a time, checking the site each time you add one. At some point if the site goes down, then disable the most recently enabled one, and see if that brings it back. If so, then don't enable that one but try enabling others. At some point (hopefully) all will be enabled except the one that causes the problem. THEN... depending on the functionality of that plug-in, either find a replacement, or investigate if they have a fix or workaround.

 

If that doesn't do it, there may be other options to try (such as re-installing fresh copies of theme files). But I'd start with the plug-ins, especially since WordPress just updated, and it's quite possible one or more plug-ins has a problem with it.