Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

max_execution_time won’t change



I had to increase max_execution_time and it’s not working no matter what I try.


I have changed a few values in .httaccess and all fields are fine but max_execution_time. I have tried to change it from Cpanel and it shows me the correct value.


I have created an info.php and it shows me the correct value but inside the theme, it still shows me 0 instead of 300. 


I have also tried to create a .user.ini file and upload it but still the same results.


Any ideas what could be the cause of that? I have tried to import some items and I got problems right away because of the execution time.


Re: max_execution_time won’t change

 1. Add the following to wp-config.php:



2. Make sure you back up .htaccess before you edit it.

Add the following to .htaccess:

php_value max_execution_time 300


3. Add the following to php.ini:

max_execution_time = 300


Thank you By


Re: max_execution_time won’t change

I can only edit wp-config and .httaccess


I don't have a php.ini file, tried to create one and save it and no luck with that either.

Rockstar I Rockstar I
Rockstar I

Re: max_execution_time won’t change

Hi Maz11!


Have you cleared both server and browser cache?


What platform are you using?  On some of the lower-tier programs resources are restricted regardless of the contents of the .ini and config files.  I typically use a Business cPanel plan if I'm having to up resources significantly.  This plan is made to allow for more intense processing, and I've NEVER had a problem accessing the resources allocated to my plan,


Also, try creating/editing the .user.ini file instead of php.ini.  On shared hosting plans, this file is what requests system/php resources.


Hope this helps,


Not Just Pretty Sites, Pretty Doggone Smart Sites

Re: max_execution_time won’t change

Hi @JMPepper,


I'm using WordPress. I have cleared both caches and still nothing. I'll have to check about the cPanel plan and take it from there.


I have created a .user.ini file and nothing has changed. What's interesting is that when I first installed the theme I made those changes and it was working. Then I thought I would do a fresh install on a clone version and it didn't work ever since.


Thank you for your advice, I'll see what I can do. 


Re: max_execution_time won’t change

Hi Maz11,

You can just add the below line of code in .htaccess

php_value max_execution_time 600

If this didn't work, deactivate all the plugins and activate one by one from Dashboard to find the faulty plugins. You can also check this guide to fix fatal error maximum execution time exceeded.

Re: max_execution_time won’t change

Seems admin pages might need some extra time for calculations and this can also be reason for cause, if you use other plugins also make requests at the same time… Having a max_execution_time with a value of 120 shouldn’t be considered that much and it should resolve this error in your site.  Thanks..