cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Green bar is not working with pages in a specific folder

Hey guys I have purchased SSL and it's working fine on the main page of my domain.

yourcascade.com but it's not working with this link yourcascade.com/social it says your connection is not secure, i have made a redirection loop for .htaccess file (http to https) after that the green lock appeared on the main page but after sometimes my browser says too many redirects and error message appeared, so after that i have to remove that redirection code.

Need help with this.

Aakash Priyadarshi
4 REPLIES 4
Helper VI

Can you show me your htaccess redirection code?

Also, while looking at the affected page, can you please press f12 and tell me the error massages you see
~Jan Mykhail Hasselbring Web Administrator @ fullstackwebsolution.com

Yeah sure

 

# 1 ---- Establish a custom 404 File not Found Page ----

ErrorDocument 404 /filenotfound.html
Options +ExecCGI
AddHandler fcgid-script .html
FCGIWrapper /usr/local/cpanel/cgi-sys/php5 .html
# 2 ---- Prevent directory file listing in all of your folders ----

IndexIgnore *

Aakash Priyadarshi
Helper V

@aakashm001 When I go to your site ether http://yourcascade.com or http://yourcascade.com/social both site pull up. only  http://yourcascade.com/social shows not secure in my browser(Chrome) due to input form for password over an insecure connection.

 

When I try to securely access your site. https://yourcascade.com loads up just fine but https://yourcascade.com/social returns a 301 Moved Permanently and redirects to http://yourcascade.com/social the non secure version of your site.

You will need to look at the .htaccess file in the /social folder if it exist and see if there is a redirect. There may be other things that redirect and you will need to check your site for any redirects that may be present.

 

@oslinux Thanks for the reply and yes there is a .htaccess file

 

Options -Indexes
Options +SymlinksIfOwnerMatch
DirectoryIndex index.php

<Files "error_log">
order allow,deny
deny from all
</Files>

<FilesMatch "(nginx|htaccess).dist">
order allow,deny
deny from all
</FilesMatch>

<IfModule mod_mime.c>
AddType image/vnd.microsoft.icon .ico
</IfModule>

<IfModule mod_expires.c>
ExpiresActive On
ExpiresDefault "access plus 1 year"
</IfModule>

<FilesMatch "\.(jpg|jpeg|gif|png|mp3|flv|mov|avi|3pg|html|htm|swf|js|css|ico)$">
FileETag MTime Size
</FilesMatch>

<IfModule mod_rewrite.c>
#SetEnv HTTP_MOD_REWRITE 1

RewriteEngine on


RewriteRule ^rewrite.php$ installation/tests/apache_rewrite.php [L]

RewriteRule ^action\/([A-Za-z0-9\_\-\/]+)$ system/handlers/actions.php?action=$1&%{QUERY_STRING} [L]

RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^([A-Za-z0-9\_\-]+)$ index.php?h=$1 [QSA,L]

RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^([A-Za-z0-9\_\-]+)\/(.*)$ index.php?h=$1&p=$2 [QSA,L]

</IfModule>

<IfModule mod_php5.c>
php_value memory_limit 128M
php_value register_globals 0
php_value post_max_size 8388608
php_value upload_max_filesize 5242880
php_value default_charset "UTF-8"
</IfModule>

 

this is the coding and I even tried to add this below...redirect engine ON

 

RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

 but then it says ERR_TOO_MANY_REDIRECTS

Aakash Priyadarshi