Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Tuesday, August 3rd at 3pm PST / 6pm EST. Learn more
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
soitre
New

Can't import xml file from blogspot to wordpress hosting

Hi,

I want to import my backup blogspot to godaddy wordpress hosting, but I always get this error when importing.

 

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 2344 bytes) in /home/content/a2pnexwpnas04_data02/09/3467409/html/wp-includes/SimplePie/Parser.php on line 343

 

My backup file size is 48MB.

 

Is there any way to fix it? Do I need to contact godaddy support?

Thank in advance.

1 ACCEPTED SOLUTION
JMPepper
Advocate VII

Hi @soitre,

 

It looks like WordPress is running out of memory when executing the SimplePie/Parser.php.

 

You can increase your memory limit in a couple of ways. Here is an example of a user.ini file:

 

memory_limit = 2048M
max_execution_time = 1600
max_input_time = 320
post_max_size = 120M
max_input_vars = 2000
file_uploads = 4
max_file_uploads = 20
upload_max_filesize = 100M

 

or you can add these lines to your wp-config.php file:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '2048M');

 

After you do either one of these, clear your cache, give your site about 15 minutes and you should be good to go if you've increased your limits enough.

 

Hope this helps,

James

Not Just Pretty Sites, Pretty Doggone Smart Sites

View solution in original post

4 REPLIES 4
Oniram
Getting Started

There is another way - you can get a SEO free plugin from Yoast. it automatically sets up your XML files plus helps you optimise your posts. I assumed that you already moved your blogspot post to WordPress. 

SeanWuzHere
Getting Started

I believe there is a 32mb file size limitation for uploads by default. There are a number of ways to fix this. For example, you could change the "upload_max_filesize" setting in php.ini if you had access to that (like if you were hosting your own Wordpress server). But if you have Wordpress on a hosted site, then it's possible you might have to ask your host for help getting that changed.

I used this Wordpress Hosting (Basic Plan) of Godaddy: https://www.godaddy.com/hosting/wordpress-hosting

Can they possible help me change? I tried to chat but the agent support could not change it.

JMPepper
Advocate VII

Hi @soitre,

 

It looks like WordPress is running out of memory when executing the SimplePie/Parser.php.

 

You can increase your memory limit in a couple of ways. Here is an example of a user.ini file:

 

memory_limit = 2048M
max_execution_time = 1600
max_input_time = 320
post_max_size = 120M
max_input_vars = 2000
file_uploads = 4
max_file_uploads = 20
upload_max_filesize = 100M

 

or you can add these lines to your wp-config.php file:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '2048M');

 

After you do either one of these, clear your cache, give your site about 15 minutes and you should be good to go if you've increased your limits enough.

 

Hope this helps,

James

Not Just Pretty Sites, Pretty Doggone Smart Sites

View solution in original post