Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Tuesday, August 3rd at 3pm PST / 6pm EST. Learn more
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Getting Started

WordPress Memory Limit

I'm looking at the Avada theme in Wordpress and under system status it says the following for WP Memory Limit:


40 MB - We recommend setting memory to at least 128MB.  To import classic demo data, 256MB of memory limit is required. Please define memory limit in wp-config.php file. To learn how, see: Increasing memory allocated to PHP.


I just wanted to know if I have to the same thing as increasing the php limit or do I have do something completely different for that and if so what do I need to do to increase the setting?


Thanks again for the help, it is really appreciated!




Add this line to your wp-config.php file:


define( 'WP_MEMORY_LIMIT', '256M' );

View solution in original post


Add this line to your wp-config.php file:


define( 'WP_MEMORY_LIMIT', '256M' );

View solution in original post

Perfect! Thank you!



Would you tell us exactly where in the php file we need to put this line. I have this problem and I am not sure where to put it and how long to wait before I see the error removed from Avada System Status.



Thank you so much. It works for me.


This did not work for me.  😞  I am trying to load a predefined layout from Divi Builder plugin.  

Hey @AmyD,


Sounds like you might have a different issue then. Can you start a new discussion topic about the plugin and the specific error you're encountering so other members might be better able to suggest a solution? 


CG - GoDaddy | Community Moderator
24/7 support available at

Hi @AmyD,

I use Avada on GoDaddy extensively.  Are you on a cPanel or managed wp?  I'll be glad to help!




Not Just Pretty Sites, Pretty Doggone Smart Sites

Hi everyone. I am using cPanel.  I have the Deluxe hosting plan.  I've abandoned using predefined layouts, and I'm just moving on with the Divi Builder and inserting modules.  For instance, I had wanted a Contact Us Page.  So, I just added a row/column and inserted the Contact form module.  Would still like to be able to take advantage of the Layouts but.....  

Hmmmmmm.  @AmyD, are you still getting a memory exhausted error or is it something different now?  Can you send a screen shot of the actual error? 




Not Just Pretty Sites, Pretty Doggone Smart Sites

Thank you JMPepper!

I never got an error displayed.  When I selected the "Load" button for the predefined layout, a progress spinner came up, and would just keep spinning.  And spinning.  I tried killing all of the processes and reloading, etc., but the load process just seemed to hang there.  I disabled all of the plugins but that one, and THEN killed processes and refreshed, and no luck. (Edit:  Meaning - after killing the processes, and restarting the load, it still would hang.  )

It was in researching this problem, that I saw the suggestion to increase the memory.  Evidently something else is going on.  As I mentioned - I have worked around that particular issue so that I could complete my task.  When I have time/energy to troubleshoot this, I will return to it.  

Thank you for your help.  

Understand the situation.  Just a quick suggestion, given the type of problems you've run into, backup up your site manually after making a few successful updates.  That way if you run into another situation where you have do some sort of workaround, you'll have working "waypoints" for developing the workaround.


Hope this helps,


Not Just Pretty Sites, Pretty Doggone Smart Sites

Hi @JMPepper,


I'm using Avada on GoDaddy. I'm using the managed WP and I'm having some issues. How long does it typically take for WP to get the newly updated configs? I updated the WP Memory Limit on the config.php file and PHP Time Limit on the .htaccess file. 


Any and all help would be appreciated!




Hi @Bpate018,


It usually takes about 15-30 minutes.  Once I've upped the limits on both the wp-config and .ini files, I go to the GoDaddy panel in WP and Flush Cache.  I then log out of the site completely and clear my browser cache.  I check the parameters about 30 minutes later and the changes should be shown.  It doesn't always take that long to take effect, though.


Hope this helps,


Not Just Pretty Sites, Pretty Doggone Smart Sites

Thanks for the quick response @JMPepper!

I made the changes last night and followed those steps but I still don't see the updated limits. If I made the changes to the files via SFTP, are there any other steps I would need to do? I was also unable to find any .ini files to make changes too. Where is that file usually located? 


Thanks for all of your help, I'm almost on my way 🙂

Hi @JMPepper,

My problem is the same for me  in Cpanel, tried all of the following (WP config, .htaccess in every folder), but the issue is still on. It seems for me that I may not allowed to increase this amount in the "PHP Settings" (screenshot attached, PHP Settings).

Who should I contact to increase this amount to the needed 256 MB?

Thanks a lot!

(deleted temporarily while i revise)

Hi I have the same question - I also need to increase my memory limit etc for Avada.  However, I'm not using cPanel so I don't understand the instructions in this conversation.  I'm on a managed wordpress package.  I called GoDaddy but they said I need to use Filezilla to... (something about .user.ini but I didn't understand).   Is anyone able to please help me with instructions?

Hey guys,

I think it depends on alot on your php version and use of Apache but I did the following:

1. open a text editor to create a TEXT ONLY file so no wordpad, MSWord, etc. use notepad or my fav notepad++ (in windows). Obv Linux has tons of easy ones.

2. paste the following line into the text file (number is seconds long) I chose 5min (3000s/60s = 5 min).

max_input_vars = 3000

3. Save it and put it into your WP root directory (same place as your wpconfig.php). Will prob fall just under your .htaccess file.

4. Go check your status. Worked for me.


Hope that helps! Took me a few hours research and I told it TO the tech support woman and she made it for me there.


Now to go find an answer to my 500 internal server errors (WP 4.7.3, Avada 5.1.x)



Hi @Shimwow


I have attached a video File below. Easy to understand. Just follow the tutorials below and increase your default PHP Limit.


 Thank You.

Really good video!
Not Just Pretty Sites, Pretty Doggone Smart Sites