cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
New

cURL error 28 on Wordpress site

I got this error when I check the Wordpress site health section. How can I fix this? I search this error on internet and its look like a hosting related problem. Can Godaddy fix this? 

 

The error is "[] cURL error 28: Operation timed out after 10000 milliseconds with 0 bytes received" 

3 REPLIES 3
Super User II
Super User II
Solution

Re: cURL error 28 on Wordpress site

Hello 

 

How to fix it ?

  • The first thing to do is to update your WordPress to the latest version if not already done.
  • Make sure your server is running a recent version of PHP and the cURL library.
  • Try to increase your Server Memory Limits settings.
  • The cURL error can be a dns related issue. Your hosting company might need to switch dns configuration to OpenDNS.
  • Ask your host if there is some limitation with wp-cron, or if loopback is disabled.
    Ask your host if there a firewall or security modules (e.g. mod_security ) that could block the outgoing cURL requests.

You can also install the Query Monitor plugin and check the status of the HTTP API Calls in the admin page where the error is displayed.

 

Zulfiqar Anees | GoDaddy Pro | Founder/CEO at FastTech Media, TechMag, and ZulWeb.

Re: cURL error 28 on Wordpress site (Not solved)

This is not a solution, just some suggestions. Don't have a big SOLVED green checkmark unless someone actually described a solution that worked for them please.

Solution

Re: cURL error 28 on Wordpress site (Not solved)

In my case: GoDaddy suggested I pay for security support to fix this and I'm trying to figure it out myself.

  • WordPress IS updated to the latest version (cPanel in Godaddy Hosting).
  • PHP IS updated to the latest version (cPanel in GoDaddy Hosting)
  • The cURL library version in the Terminal (cPanel in GoDaddy Hosting) is 7.19 while in WordPress the cURL version reported by WordPress Site Health is 7.52.0 OpenSSL/1.0.2k The latest cURL version (https://curl.haxx.se/docs/releases.html) is 7.66, but I see no way to update this.
  • Updated Server Memory Limits, problem remains.
  • "The cURL error can be a dns related issue. Your hosting company might need to switch dns configuration to OpenDNS." (Not sure what to do with this one, but "curl -I https://mysite.com" works fine at the terminal.)
  • Ask your host if there is some limitation with wp-cron, (Not sure how this would have any effect. The wp-cron module is for firing jobs like clean up in the background this is an immediate failure so it seems irrelevant.
  • "or if loopback is disabled." Where would we check that?
  • "Ask your host if there a firewall or security modules (e.g. mod_security ) that could block the outgoing cURL requests." Disabled all security plugins and the problem remained.
  • the Query Monitor plugin is great, showed me a lot, but not what actually blocked cURL.

In my case the fix was to disable ALL plugins, then the Health Check passed, so I enabled them one by one and found that there was code in an old quiz plugin that was causing both of my errors:  "The REST API encountered an error" and later loading was "Your site could not complete a loopback request".

 

The culprit was the plug-in Chained Quiz, even the most recent version of which ( Version 1.1.7.1 ) caused the errors in the Health Check. I notified the developer of this WordPress plug-in of the problem and will just not use it for now.

Solved? Not yet, but a lot closer. The tips above (which I also found elsewhere) caused me a day of trying to track this down when really just disabling all plugins and checking them one by one would have done it in 15 or 20 minutes. I hope this helps someone!