• GoDaddy Community
  • Websites + Marketing | Website Builders
  • Websites + Marketing | Website Builders

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 

    Transferred website to a new web host, links are not working **HELP PLEASE**

    The website is contained in a zip folder (packaged by previous web host), I extracted the files into the new web host in CPanel but the links aren't working. Can someone help me? I am new to web designing and my first client is frustrated (rightfully so) with her site being down almost 2 months because of my lack of knowledge in transferring her website to a new web host. www.marcielsaban.com

    4 REPLIES 4
    Rockstar II


    @njean777 wrote:

    The website is contained in a zip folder (packaged by previous web host), I extracted the files into the new web host in CPanel but the links aren't working. Can someone help me? I am new to web designing and my first client is frustrated (rightfully so) with her site being down almost 2 months because of my lack of knowledge in transferring her website to a new web host. www.marcielsaban.com


    It seems that you didn't unzip the files properly, the links show the the directories are not pointed to the correct spot. Have you tried researching it in Google at all? I've worked on and moved several dozen wordpress sites in the past and have never had the issues, the only issues I've had is that I was point the links in the wrong direction or I didn't have the directories setup correctly. I found this article useful: https://www.siteground.com/kb/how_to_transfer_your_website_to_another_host/

    Rockstar II

    One more thing. Did you transfer the files into the main root of the site?...meaning, when you access the site via FTP the main files are in the main directly and the subdirectories are listed as folders?

    I used the Cpanel to wizard to upload and unzip file.


    @justingodfrey wrote:

    One more thing. Did you transfer the files into the main root of the site?...meaning, when you access the site via FTP the main files are in the main directly and the subdirectories are listed as folders?


     

    Also, try going into settings > permalinks and set the links to be post title.  I note that is what is showing on the link but the link http://www.marcielsaban.com/interior-design/ calls up a 404.  However, the link http://www.marcielsaban.com/?p=1 does call up a page.  Try setting the permalinks the same way you had them on the old site.

    Keep on Coding!
    Mark Cicchetti - There are 10 kinds of people... those who understand binary and those who don't.