cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
New

Domain forwarding working intermittently: http:// to http://www.

Hello,

 

My domain, http://macrosfirst.com, is set to forward to http://www.macrosfirst.com. However, this has only been working intermittently in the last few days.

 

This is what happens when it does not work. www.macrosfirst.com is applied but with some nonsensical directory added to the URL which then causes it fail. Trying again will yield different directories.  404_Not_Found.png

My www CNAME points to my site on AWS S3 and that direct address is working perfectly fine so I think the issue is with GoDaddy's redirect. I haven't made any changes to GoDaddy nor AWS in months so I have no idea why it stopped working recently.

 

Has anyone seen this before? It's super annoying. Thank you.

23 REPLIES 23
Retired
Not applicable

Hi @jbock,

 


@jbock wrote:

Hello,

 

My domain, http://macrosfirst.com, is set to forward to http://www.macrosfirst.com. However, this has only been working intermittently in the last few days.

 

This is what happens when it does not work. www.macrosfirst.com is applied but with some nonsensical directory added to the URL which then causes it fail. Trying again will yield different directories.  404_Not_Found.png

My www CNAME points to my site on AWS S3 and that direct address is working perfectly fine so I think the issue is with GoDaddy's redirect. I haven't made any changes to GoDaddy nor AWS in months so I have no idea why it stopped working recently.

 

Has anyone seen this before? It's super annoying. Thank you.

 


Yes, isn't it..........

You have no CNAME record, or not where it should be, your godaddy zone.........

Would you mind to elaborate  ?
There's an option to forward a domain and we are using it, the cname entry is autopopulated by that forward option.

This is a trace for one months+ back:

curl -v -L macrosfirst.com
* Rebuilt URL to: macrosfirst.com/
*   Trying 50.63.202.10...
* TCP_NODELAY set
* Connected to macrosfirst.com (50.63.202.10) port 80 (#0)
> GET / HTTP/1.1
> Host: macrosfirst.com
> User-Agent: Twitterbot
> Accept: */*
>
< HTTP/1.1 302 Found
< Connection: close
< Pragma: no-cache
< cache-control: no-cache
< Location: /
<
* Curl_http_done: called premature == 0
* Closing connection 0
* Issue another request to this URL: 'http://macrosfirst.com/'
* Hostname macrosfirst.com was found in DNS cache
*   Trying 50.63.202.10...
* TCP_NODELAY set
* Connected to macrosfirst.com (50.63.202.10) port 80 (#1)
> GET / HTTP/1.1
> Host: macrosfirst.com
> User-Agent: Twitterbot
> Accept: */*
>
< HTTP/1.1 301 Moved Permanently
< Cache-Control: max-age=900
< Content-Type: text/html
< Location: http://www.macrosfirst.com
< Server: Microsoft-IIS/7.5
< X-AspNet-Version: 4.0.30319
< X-Powered-By: ASP.NET
< Date: Sun, 09 Jul 2017 03:19:32 GMT
< Content-Length: 0
< Age: 1
< Connection: keep-alive


And this is a trace from today:

curl -v -L macrosfirst.com
* Rebuilt URL to: macrosfirst.com/
*   Trying 50.63.202.13...
* TCP_NODELAY set
* Connected to macrosfirst.com (50.63.202.13) port 80 (#0)
> GET / HTTP/1.1
> Host: macrosfirst.com
> User-Agent: curl/7.51.0
> Accept: */*
>
< HTTP/1.1 302 Found
< Connection: close
< Pragma: no-cache
< cache-control: no-cache
< Location: /YYNhZ/
<
* Curl_http_done: called premature == 0
* Closing connection 0
* Issue another request to this URL: 'http://macrosfirst.com/YYNhZ/'
* Hostname macrosfirst.com was found in DNS cache
*   Trying 50.63.202.13...
* TCP_NODELAY set
* Connected to macrosfirst.com (50.63.202.13) port 80 (#1)
> GET /YYNhZ/ HTTP/1.1
> Host: macrosfirst.com
> User-Agent: curl/7.51.0
> Accept: */*
>
< HTTP/1.1 302 Found
< Connection: close
< Pragma: no-cache
< cache-control: no-cache
< Location: /
<
* Curl_http_done: called premature == 0
* Closing connection 1
* Issue another request to this URL: 'http://macrosfirst.com/'
* Hostname macrosfirst.com was found in DNS cache
*   Trying 50.63.202.13...
* TCP_NODELAY set
* Connected to macrosfirst.com (50.63.202.13) port 80 (#2)
> GET / HTTP/1.1
> Host: macrosfirst.com
> User-Agent: curl/7.51.0
> Accept: */*
>
< HTTP/1.1 301 Moved Permanently
< Cache-Control: max-age=900
< Content-Type: text/html
< Location: http://www.macrosfirst.com
< Server: Microsoft-IIS/7.5
< X-AspNet-Version: 4.0.30319
< X-Powered-By: ASP.NET
< Date: Sun, 27 Aug 2017 02:54:41 GMT
< Content-Length: 0
< Age: 1
< Connection: keep-alive

You can clearly see that there is an extra step now that wasn't there before.

Retired
Not applicable

Yes @andruli,

 

when i I check for a CNAME record I can't find one..... I would love to explain in more simple terms but I am having an easy Sunday.  Perhaps it's just me today, but I can't find one!

@Retired - This is my current CNAME and it's been unchanged for months. Where it points is valid.

 

Domain_Manager.png

 

You're saying you can't find a CNAME for this?

Retired
Not applicable

A few things @jbock@andruli......

 


@jbock wrote:

@Retired - This is my current CNAME and it's been unchanged for months. Where it points is valid.

 

Domain_Manager.png

 

You're saying you can't find a CNAME for this?


Your site is as obscure as your post are vague as your identity on the forum (how many different personas do you have exactly?)

 

Your first query points to a forwarding problem for macrosfirst.com...... yes?

There is no CNAME for macrosfirst.com:

 

bash-3.2# host -t CNAME macrosfirst.com

macrosfirst.com has no CNAME record

bash-3.2# 

 

We agree? 

 

Then there is the fact:

www.macrosfirst.com is an alias for www.macrosfirst.com.s3-website.us-east-2.amazonaws.com.

 

And am I to type the full sack full of.... www.macrosfirst.com.s3-website.us-east-2.amazonaws.com.

Then yes your site resolves.

 

I suggest you sort it out yourself or phone support thank you............... I can't help you as this is an account specific problem, only support have access to your account.

 

 

@jbock Did you find a solution to this problem? We are experiencing exactly the same issue.

@nicoraffo - No. Smiley Sad

We called GoDaddy phone support and they were unable to reproduce it. The support agent also refused to run a curl command, with which you can absolutely see the issue, which is incredibly annoying.

We've tried deleting and recreating the forwarding rule with GoDaddy and it's still returning bad URLs intermittently. This appears to definitely be an issue with GoDaddy's forwarding.

@jbock That's about where we're at as well. No help from support. 50% of our curl requests get the weird redirect, and the new url we're redirected to fails intermittently. We'll update if we get anywhere with it. Thanks!

We've also reproduced the problem by running the curl command after SSH'ing to offsite servers. It's most definitely a Godaddy issue.

 

Support conceded that it's a problem on Godaddy's side and that they're working to resolve it. No ETA.

@nicoraffo  - Nice! Do you have a support ticket reference number that you can share? I'm talking with support now and they seem totally clueless and are trying to blame my host... which makes no sense whatsoever.

@jbock They couldn't/wouldn't give us a reference number, but this was via chat support. Chat seemed to work better since we can copy/paste the tests we've run.

 

For example we pulled the IP of our domain and curl'ed that:

 

[~]$ curl -I 50.63.202.1
HTTP/1.1 302 Found
Connection: close
Pragma: no-cache
cache-control: no-cache
Location: /TSjZZ/

And also showed that that is a GoDaddy IP.

 

The problem is not yet fixed, btw. Vague assurances continue 😞

Hey, we found a quick workaround that may work for you..

 

http://yourdomain.com should redirect to http://www.yourdomain.com

 

however instead it redirects to 

http://www.yourdomain.com/<random 5 characters>

This is not working. The  <random 5 characters> are added by the redirect chain within godaddy domain forwarding application (why this is so hard to understand by godaddy support is beyond me)

 

So how about redirecting to

 

http://www.yourdomain.com/?

 

In this case, when godaddy adds the extra characters to the URL, they become parameters and don't cause a 404..

 

http://www.yourdomain.com/?<random 5 characters>

 

should work now..

 

 

That's a clever workaround. But seriously GoDaddy needs to get their **bleep** together and resolve this issue ASAP--this is completely unacceptable.

 

I've spent hours researching about this and apparently this has been an issue for GoDaddy for years and they continue to deny that it is an issue on their end, even though it's clear that they are wrong.

 

This is ridiculous, and we will be switching to another registrar. I suggest everyone reading this to do the same.

Hi @Daniele - 

 

Thanks. We implemented this a few days ago so to prevent users from getting 404s which is good, but it's still so janky of GoDaddy that this is what we have to do. Further, for some site preview cards like on Slack, Twitter, and FB, the extra 302s and 301s prevent them from properly constructing a preview of our site. 😞

Hmmm I tried this workaround of adding the / and it did not seem to fix the issue. It still intermittently generates the random string of letters after the / causing the 404 error. I've tested thru emulators and third parties like https://developers.google.com/speed/pagespeed/insights

nomader, don't forget to add the ? after the / (http://www.yourdomain.com/?). I have tried this and it works. Thanks to Daniele above for this quick temporary workaround until GoDaddy people get their act together.  Daniele should replace the arrogant, obnoxious, vague and worthless rammsteinium who calls himself (herself?) a "GODADDY PRO TRUSTED ADVISOR."

See the following URL for a whole string of other people who are having the same problem that GoDaddy is refusing to acknowledge and fix.
https://www.godaddy.com/community/Managing-Domains/My-domain-name-not-resolving-correctly-6-random-c...

nomader, you wrote: "GoDaddy continues to deny that there are any issue on their end, even after placing me on hold for extended periods to chat with their escalated support team. They state that my DNS settings and 301 redirects are setup properly and say that it's an issue with my host."  I am having the same problem and GODADDY IS MY HOST! GODADDY IS THE PROBLEM! Is anybody at GoDaddy monitoring these community boards??? Time to acknowldge and fix the problem!!!

I discovered that this problem is not only a GoDaddy forwarding problem, but also a problem with GoDaddy hosted domains.  I have a domain that is registered and hosted with GoDaddy.  Oftentimes when I refresh my GoDaddy hosted webpage, it automatically adds the random letters. 

 

GoDaddy appears to be very hush, hush to the customers about what is causing the problem. I am going to take a wild guess and say that these problems are a result of GoDaddy's new Domain Connect 2.0 in which we now have a new ugly CNAME in our DNS managers:

 

CNAME     _domainconnect     _domainconnect.ss.domaincontrol.com

 

From reading this article below, it seems their ultimate purpose is to expand their sales by putting every domain to use (nevermind all the grief that it causing their customers). 

 

https://engineering.godaddy.com/seamlessly-connecting-domains-services-domain-connect-2-0/

Retired
Not applicable


@surething wrote:

I discovered that this problem is not only a GoDaddy forwarding problem, but also a problem with GoDaddy hosted domains.  I have a domain that is registered and hosted with GoDaddy.  Oftentimes when I refresh my GoDaddy hosted webpage, it automatically adds the random letters. 

 

GoDaddy appears to be very hush, hush to the customers about what is causing the problem. I am going to take a wild guess and say that these problems are a result of GoDaddy's new Domain Connect 2.0 in which we now have a new ugly CNAME in our DNS managers:

 

CNAME     _domainconnect     _domainconnect.ss.domaincontrol.com

 

From reading this article below, it seems their ultimate purpose is to expand their sales by putting every domain to use (nevermind all the grief that it causing their customers). 

 

https://engineering.godaddy.com/seamlessly-connecting-domains-services-domain-connect-2-0/


You hit the nail on the head!! And perhaps you can understand my frustration too at not being able to fully recognise the problem immediately because we Pro members are not godaddy employees with inside knowledge. We find things out like the rest of you.

Godaddy in their efforts to make things easy (usually for CMS users) and more user friendly ( you don't need a brain to change a CNAME), have messed up!!!!!!! Then left us all to go figure............

@surething I thought I tried the ? as you suggested but perhaps I did it wrong. In any event, I ended up finding a different solution which I posted in another thread. Here it is for anyone interested:

 

Good news! I found a simple solution to this issue that is plaguing so many of us....

 

There's a great free service called WWWizer.com which will handle the redirect for you. All you need to do is create an A Record that points to their IP address and they'll 301 your naked domain traffic over to your www'd domain. 

 

Specifically this solution is to solve the issue of pointing your naked domain (domain.com) to your www.domain.com without encountering the 404 error caused by the random string of letters after the / that GoDaddy's redirect is causing.

 

Step 1: delete your current forward.

Step 2: change the "value" in your A record from "Forwarded" to the WWWizer IP address.

Step 3: test using third party emulators to ensure that your naked domain is resolving properly.

Step 4: help spread the word to others that are affected by this issue.

 

Ultimately, this is just a workaround, not a permanent solution IMO. I am in the process of transferring all of my domains to Google Domains. I have lost all confidence and trust in GoDaddy based on their extremely poor handling of this forwarding issue.