Showing results for 
Show  only  | Search instead for 
Did you mean: 

Ninjaforms contact form on Wordpress site not sending email notification

I have a Ninja Forms contact form on my Go Daddy hosted Wordpress site.  I'm testing it and receiving notifications in the form Submissions but no emails are coming through.

Help please?

Super User II



Two things to check....


Settings > General: make sure you have an email address there that is the same as your website domain.  Same goes for the designated email address in Ninja forms.  Needs to be an address from your domain.


If that doesn't resolve the issue, try a plugin such as: WP Mail SMTP.


HTH! 😉

"I never lose. Either I win or I learn." ~ Me

Thanks.  That didn't work.  I've tried the plug in but I get this message saying 


Your host may have installed a firewall

You may have incorrectly tried to use SSL over port 587.  Check your encryption and port settings


So am a bit stuck...





Now that you've eliminated these two potential causes you then have to contact GoDaddy support to run that by them -- including relaying the error message you are receiving to get their help and/or suggestions. 😞

"I never lose. Either I win or I learn." ~ Me

Tried that - apparently the server can send emails...

I can send test emails from MailBank using php, but I'm still not getting submissions/emails from the Ninja Forms contact form.  They come into submissions but not to my email



Look in your spam folder.   For some reason mine were getting sent to my spam folder in the hosted email because of the way Wordpress sends them out.   This was with the email essentials plan.  

Test emails from MailBank using php are indeed going in Junk, but mail from the contact form isn't going anywhere.  


I might give up on Ninja Forms and just put in a Mailto: see if that works...

Definitely odd.   The default install worked fine for me without really changing anything.  are you using Godaddy's hosted email or another service for email?   I didn't even really have to edit the actions on the form as it defaults to send it to the admin account.   

Office 365 email through Go Daddy managed Wordpress

So it seems I can't get an SMTP port no...

Odd.  exact same setup as me.