Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Wednesday, July 28th at 3pm PST / 6pm EST. Learn more
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Getting Started

Unable to install plugins or new themes

I have a wordpress site up and running but have been unable to install any plugins or install a new theme.

When I try installing themes I always get update failed and 

When I try installing a plugin it fails with this message - Installation failed: 500 Internal Server Error <!--[if lte IE 6]><![endif]--> Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request.


Hope I'm just missing something simple and easy to fix - thanks in advance for any help 🙂


Hi All. If anyone is having trouble installing plugins/themes or updating installed plugins, there's a few steps you can try.

If after trying these, you are still encountering errors, you may want to call Support so they can review your hosting plan and the specific errors you are receiving.


Gary - GoDaddy | Community Moderator
24/7 Support | Check System Status

View solution in original post

Super User I Super User I
Super User I

Is this a browser specific issue @chaz1819 or is this happening with any browser you choose? Are there specific packages that you can't upload properly or is this happening with everything?

...turns out that my two cents is worth less or more depending on the current exchange rate.

roy darling *my posts seem a lot shorter in my head

Getting Started

Hi Roy, seems to be with all plug ins and best I can do with a theme upload is partial.  Tried different browsers but no luck 😞

Are you using the Managed WordPress option from GoDaddy @chaz1819. I assume that your internet connection is sound and it doesn't take an extraordinary amount of time to upload your files? Have you tried unzipping the packages and uploading them via FTP like using FileZilla: FTP settings to upload your website? Perhaps calling or chatting with support might be worthwhile? 

...turns out that my two cents is worth less or more depending on the current exchange rate.

roy darling *my posts seem a lot shorter in my head

Getting Started

Thanks for the help Roy, things seem to work well with themes and plug-ins if I download off wp and then upload through file manager.

do you still fine problem if update directly from word press admin panel?

For me it doesn't work anything. I tried reinstaling everything. Same error over and over. Cant do anything on my sites. PLease help!

On that htaccess file i cant find, i cant see it or find option to view invisible files...

I have exact same problem!!!!

Getting Started

I had the same issue (by using the default install from WP). I fixed it by uploading the plugins manually.


Every time I try to install one, I get an 500 Internal Server Error. I managed to get a few installed by changing the PHP version, then changing the .htaccess to .htaccess_old, but overall, it's still not working. I'm running a single Wordpress site on Plesk via GoDaddy.


I'm not really a tech person, so this is beyond frustrating for me. I've tried a lot of the solutions online but no dice. I really appreciate any help y'all can give me.




I would like to follow one tutorial in youtube and purchase these theme for 59 USD but unfortunately i cannot install it I email the website where i purchase it, they said i should request to the domain provider to allowed this theme to be install on my wordpress, Can you help me guys maybe you experience same problem, and do you know how can I contact godaddy im basing Dubai UAE, do they have email?..

Thank you

Hi, I have installed an "Easy Table" plugin from godaddy wordpress plugin list and activated it. But I am not able to see the plug in on the pagebuilder "Add Content" option. Can someone pls help.



I have a Managed Wordpress site under construction that I need to install CiviCRM. I was able to upload the plugin file and start the setup process. However, I got stuck in the first step because CiviCRM needs the MySQL  Database Settings to connect (MySQL server, username, password).


I couldn't find this information in my account setting page. Is there a way to get this information?





Every site was getting a php error at some point the other day and now the option for adding plugins in the admin cp dissapeared. What's going on?


I purchased a domain and managed WordPress through godaddy today.  I have a few issues.


1. The WordPress admin page only allows me to view themes and manipulate the site's appearance.

I have used WordPress before and know that there are more options.

2. I cannot add plugins. GoDaddy's troubleshooting guide takes me back to its WP admin page which only has themes.

3. I cannot login to my site via


I though using Godaddy for both my domain and WordPress hosting would be seamless but it appears to be limiting compared to what I can do on WordPress directly.





I upgraded, paid for migration but my site is down. I installed WP into the new business hosting account but the theme will not appear. I believe the version of WP I paid to migrate is below their current WP App choices.




Many thanks in advance.


Lisa aka HypoGal 


the wordpress start wizard is not allowing me to use theme and proceed furthure





I have a problem with upload limit using third party theme, godaddy is not helpful, i need to increase the file upload limit. please help

I was having the same problem. I just now went into my GoDaddy account to the Control Panel. There is an option there to Manage Plugins, Manage Themes. I was able to use that tool to upload my plugins without any problems. 


Can you please update WordPress because certain themes are creating a Parse Error.  You have to go into "file manager" and delete the theme to even operate WordPress.  I was told the host needs to update WordPress on the database side...currently running outdated 5.5 Thank you.


Parse error: syntax error, unexpected T_FUNCTION in /home/content/t/e/r/terry27/html/test/wp-content/themes/aza-lite/inc/customizer.php on line 221

Getting Started

I have an older site on my Managed WordPress account, which doesn't have Page Builder. I have tried adding Page Builder via SFTP, but I get the below errors and it doesn't work correctly to re-build the home page. The URL I am working with is


How can I add Page Builder to this site correctly?


Warning: Missing argument 2 for wp_register_script(), called in /home/content/p3pnexwpnas09_data01/42/2494442/html/wp-content/plugins/button-maker/buttons.php on line 124 and defined in /home/content/p3pnexwpnas09_data01/42/2494442/html/wp-includes/functions.wp-scripts.php on line 145

Warning: Cannot modify header information - headers already sent by (output started at /home/content/p3pnexwpnas09_data01/42/2494442/html/wp-includes/functions.wp-scripts.php:145) in /home/content/p3pnexwpnas09_data01/42/2494442/html/wp-includes/pluggable.php on line 1179

Warning: Cannot modify header information - headers already sent by (output started at /home/content/p3pnexwpnas09_data01/42/2494442/html/wp-includes/functions.wp-scripts.php:145) in /home/content/p3pnexwpnas09_data01/42/2494442/html/wp-includes/pluggable.php on line 1179