cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Wordpress 4.5.2 update permissions issue

I've never had an issue with any wordpress updates. Trying to get to 4.5.2 is failing with the following:

 

Warning: copy(D:/Hosting/11909919/html/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: Permission denied in D:\Hosting\11909XXX\html\wp-admin\includes\class-wp-filesystem-direct.php on line 217

The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.: wp-admin/includes/update-core.php

 

The site is on a windows server running PHP 5.3, IIS 7.0, and ASP.net 4.0/4.5. The code it references is below and the line starting with "$rtval" is line 217.

	public function copy($source, $destination, $overwrite = false, $mode = false) {
		if ( ! $overwrite && $this->exists($destination) )
			return false;

		$rtval = copy($source, $destination);
		if ( $mode )
			$this->chmod($destination, $mode);
		return $rtval;
	}

Thoughts/suggestions greatly appreciated.

3 REPLIES 3
Community Team
Community Team

That error typically indicates that some or all of the files required for the update do not have the permissions set properly to enable the update to complete.  You'll want to check the current permission settings in both the wp-content and wp-content/upgrade folders.  You can use the following guide as a reference for what the permissions should be: http://codex.wordpress.org/Changing_File_Permissions.  

 

Of course, if you're not able to track down any issues with the permissions and you continue to get that error, please give our live support a call and we'll be happy to investigate with you.  Thanks.  

Thank you. I will try that.

How do you check and edit the current file permissions in managed WordPress hosting?