cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

online users not working anymore

Hello, i run my website before on godaddy shared hosting then i shift to vps without any problems 2 years back, then i decied to downgrade my vps to shared hosting account.

after that my website not working fine, session is not working fine where online users not appear and comments not added to database, all others options is working great.

i tried to switch between php version and edit the save path for session , but still not working.

 

my question why this happened , and how to downgrade php version on shared hosting to older version which is not listed on cpanel?

 

please note that the script requirements is:

 

System requirements

PHP 5.0+

MySQL 4.1+

Recommended

PHP 5.2+

PHP allow_url_fopen enabled or cURL

GD library with FreeType library

mod_rewrite

mod_expires

 

now over one year i cant fix it and im thinking to move to another hosting company because of that.

any fix for it?   i asked the programmer and he said it should be fine but it was working fine on the old hosting accounts in godaddy , so what is the deference between old hosting accounts and new hosting accounts.

 

also i tried to install fresh copy of the script and still not working , the script is www.onarcade.com

any help or support please what should i do ? i dont like to leave godaddy after using it for over 14 years.

Regards

 

3 REPLIES 3
Former Employee

Hi lobking,

 

I would highly recommend reaching out to the creator of that application as using an only php version such as php 5.2, can put your entire site at risk as that version has not seen any security patches in a very very long time. 

 

In most cases, applications should function on php 5.6 if they worked on php 5.2. I would recommend verifying the settings within the application to see if there is any sort of cache options that could be distorting how the site is displayed. As well, the features such as users appearing online could have functioned with a different php module that may not be enabled just yet. As it stands, I would suggest reaching out to onarcade support and ask them exactly what php modules are needed for the site to function and from there, update these in the php version selection feature built into cPanel. 

 

Hope this helps! 

~Jay

Hi Jay

 

Thanks for your support

im keep trying to contact him but it looks the owner is very busy these days, he is very nice man.

 

this is last reply from him:

Hello,

I'm good, just been very busy.

What do you mean by it doesn't work on Godaddy anymore? onArcade 2 doesn't support PHP7, so maybe if they have upgraded their PHP version then that is the problem, but then your website would be completely down and only errors. It would be possible to get it working, it would be just a lot of work, so hopefully they haven't upgraded yet and it's something else.

But about onArcade, I'm actually still working on it. Haven't been able to release anything because I've been very busy with other things and I can't release a small update to make it compatible with PHP7, a huge update is necessary.  I'm kind of hoping that I can release it before most hosts will go completely over to PHP7.
 
==============
 
i dont think the php version is the problem, because all other functions is working right like submit  report page , report comments every thing is fine , just online users and adding new comment is not working, i have over 50 000 comments ,  i tried to move to wordpress by adding comments with sql commands it is working fine, but i like to use this script.
 
btw there is anyway i can know what is deference between old vps running simple control panel / or old webhosting accounts (last year)
 
anyway im still waiting him till he have time to take look on it , i will reply with the solution if its fixed.
 
thanks 

btw , i mean comments not added is : when visitor submit comment , ajax box shows that comments is submitted and waiting for approval , or if im member of the website the comments is added find but when refresh page there is no comments at all , i checked the database and the comment is not added to database at all, once online users not working fine, thats mean session is not working fine (maybe). other function like register reprt comments etc working fine.

 

website not show any errors

 

also im trying to install fresh copy with completly new database and  the same problem there only cant add comments and online users not working